Freebox Server (Delta V7 / Revolution V6 / Server Mini 4K)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie LAN → Bridge
  • Assignée à Personne
  • Système d'exploitation Tous
  • Sévérité Moyenne
  • Priorité Normale
  • Basée sur la version 3.5.2
  • Due pour la version Non décidé
  • Date d'échéance Non décidé

FS#22837 - Perte de la connexion ipv4 en mode bridge

Bonjour,

Freebox V6 Serveur à jour (3.5.4) en mode bridge.

Les connectivités ipv4 et ipv6 sont fonctionnelles, puis, au bout de quelques minutes/heures, la connectivité ipv4 ne fonctionne plus.

La TV sur le Player V6 fonctionne toujours, l’accès Internet ipv6 fonctionne lui aussi toujours mais en ipv4 il m’est impossible d’aller plus loin que la gateway (x.x.x.254) qui répond bien au ping. Un ping sur 8.8.8.8 par exemple reste sans réponse...

J’ai l’impression qu’il faut systématiquement revenir en mode routeur puis revenir en mode bridge pour rétabli l’ipv4 pour quelques temps.

Cette tache ne dépend pas d'autre tache

Damien (dough29)
Friday 14 September, 2018 19:43:33

Je confirme que le fait de revenir en mode routeur puis retour en mode bridge rétablis la connectivité ipv4 instantanément pour quelques temps.

Damien (dough29)
Saturday 15 September, 2018 12:10:43

J'ai développé un petit script permettant d'automatiser le passage mode routeur → mode bridge en cas de perte de l'IPV4 : https://github.com/dough29/FreeboxBridgeIPV4Checker

Damien (dough29)
Sunday 16 September, 2018 08:22:03

Je dispose du Freebox Player V6 ainsi que du Player Mini 4K en multiposte.

Je constate que lorsque ces équipements ne sont pas allumés la connectivité IPV4 semble stable.

En gros cette nuit aucune coupure entre minuit et 9h30 et dès que j'ai allumé le Player V6 une perte de connectivité IPV4 a été constatée, j'ai ensuite allumé le Player Mini 4K et pareil plusieurs pertes ont été constatées.

J'avais activé une capture de paquets sur l'interface WAN de mon routeur, j'ai isolé les trames entre le dernier ping OK et le 1er ping KO (environ 5 secondes), analyse en cours mais je crains que ça ne dépasse rapidement mes compétences...

Damien (dough29)
Sunday 16 September, 2018 11:00:30

Je parviens à reproduire de façon systématique le problème dans les conditions suivantes :

- Freebox V6 Player allumé sur une chaine TV
- Freebox Mini 4K Player allumé sur l'écran d'accueil

Jusqu'ici aucune perte de la connectivité IPV4.

- Accès à "Freebox TV" depuis l'écran d'accueil de la Freebox Mini 4K Player

Au bout de quelques secondes l'image se fige et je constate la perte de la connectivité IPV4 au niveau de la Freebox V6 Server.

Passage en mode routeur puis passage en mode bridge = IPV4 de nouveau fonctionnelle.

Jordy Provost (JPFree)
Friday 28 September, 2018 19:32:41

Bonjour,

Regardez si le problème n'est pas similaire aux tickets FS#22370, FS#22379 et FS#22818

Après avoir passé la box en mode routeur et rebridge, ou avoir redémarré la Freebox, regardez dans les journaux de la freebox pour voir si le 1er ping perdu ne correspond pas à une perte de la ligne ?

Si c'est le cas, merci de voter sur ces tickets :)

Quand vous parlez de la Gateway, vous parlez de votre routeur, ou de la Gateway Free (ce qui serait bizarre, car si vous pinguez la Gateway Free vous avez de l'IPv4 qui sort) ?

Damien (dough29)
Friday 28 September, 2018 19:48:16

Bonjour,

merci pour ce commentaire !

Dans l'historique (c'est bien ça les logs ?) je ne vois aucune déconnexion pour ma part.

Lorsque cela se produit je peux très bien être sur un live YouTube (en ipv6 donc) et ne constater aucune coupure !

Il n'y a que lorsque je souhaite aller sur un site "ipv4 only" (Amazon) que je constate le problème ^^

Quand je dit que je peux pinger la gateway, c'est bien la gateway Free, qui commence tout comme mon ip publique, mais avec 254 à la fin :D C'est là que je ne comprends vraiment pas comme c'est possible de ne plus accéder à Internet ipv4 !

Le vote pour les tickets mentionnés est fait depuis un petit moment déjà :D

Au plaisir en tout cas, pour l'instant je me régale avec du double NAT cracra.

Neustradamus (Neustradamus)
Friday 25 January, 2019 03:13:56

Récapitulatif, c'est donc lié à :
- https://dev.freebox.fr/bugs/task/10011

- https://dev.freebox.fr/bugs/task/12446

- https://dev.freebox.fr/bugs/task/15672

- https://dev.freebox.fr/bugs/task/15800

- https://dev.freebox.fr/bugs/task/15952

- https://dev.freebox.fr/bugs/task/18505

- https://dev.freebox.fr/bugs/task/19260

- https://dev.freebox.fr/bugs/task/19261

- https://dev.freebox.fr/bugs/task/19655

- https://dev.freebox.fr/bugs/task/19659

- https://dev.freebox.fr/bugs/task/19728

- https://dev.freebox.fr/bugs/task/20226

- https://dev.freebox.fr/bugs/task/20460

- https://dev.freebox.fr/bugs/task/20908

- https://dev.freebox.fr/bugs/task/21048

- https://dev.freebox.fr/bugs/task/21159

- https://dev.freebox.fr/bugs/task/21190

- https://dev.freebox.fr/bugs/task/21303

- https://dev.freebox.fr/bugs/task/21657

- https://dev.freebox.fr/bugs/task/21843

- https://dev.freebox.fr/bugs/task/22284

- https://dev.freebox.fr/bugs/task/22301

- https://dev.freebox.fr/bugs/task/22321

- https://dev.freebox.fr/bugs/task/22337

- https://dev.freebox.fr/bugs/task/22346

- https://dev.freebox.fr/bugs/task/22370

- https://dev.freebox.fr/bugs/task/22379

- https://dev.freebox.fr/bugs/task/22402

- https://dev.freebox.fr/bugs/task/22458

- https://dev.freebox.fr/bugs/task/22464

- https://dev.freebox.fr/bugs/task/22497

- https://dev.freebox.fr/bugs/task/22541

- https://dev.freebox.fr/bugs/task/22580

- https://dev.freebox.fr/bugs/task/22593

- https://dev.freebox.fr/bugs/task/22802

- https://dev.freebox.fr/bugs/task/22818

- https://dev.freebox.fr/bugs/task/22837

- https://dev.freebox.fr/bugs/task/22895

- https://dev.freebox.fr/bugs/task/22928

- https://dev.freebox.fr/bugs/task/23539

Damien (dough29)
Thursday 11 April, 2019 19:42:59

J'ai voulu tenter à nouveau l'aventure ce soir, ça n'a pas duré longtemps...

Comme vous le voyez quand ça plante il n'est plus possible d'accéder à Internet malgré le ping OK sur la gateway Free...

C'est général comme problème ou certaines personnes arrivent tout de même à tourner en mode bridge sans soucis ?

utopik (utopik)
Sunday 14 April, 2019 21:14:52

Idem ici... ça me rends dingue...

J'ai fait du double NAT du coup, mais c'est moche et moins simple à gérer...

Que fait Free !?

Damien (dough29)
Monday 15 April, 2019 05:49:24

Pareil double NAT... lourd...

Faudrait relancer tous les sujets avec "bridge" dans le titre ou alors en créer une nouvelle palanquée !

Damien (dough29)
Tuesday 16 April, 2019 15:46:54

Note de la MAJ 4.0.5 du jour :

"Note additionnelle:
L’IPv6 est délivré aujourd’hui sous forme de tunnel (6RD) au dessus l’IPv4 (dit natif). En raison des évolutions internes de notre réseau, le système va progressivement être inversé, et c’est désormais l’IPv6 qui sera natif, et l’IPv4 délivré sous forme de tunnel.

Pour cette raison, désactiver l’IPv6 complètement sur une Freebox revient à potentiellement diminuer les performances réseaux, donc nous enlevons la possibilité de désactiver celui-ci globalement. Cette fonction avait été introduite il y a plus de 10 ans au même moment que la fonction IPv6 de la Freebox, afin d’éviter les problèmes d’interopérabilité avec les systèmes d’exploitation de l’époque.

Notez qu’il est toujours possible de désactiver l’IPv6 sur le périphérique lui-même."

Plus qu'à attendre, en espérant que seuls les Delta ne soient pas concernés...

Damien (dough29)
Tuesday 16 April, 2019 15:47:25

J'ai oublié le lien de la source : https://dev.freebox.fr/blog/?p=5382

Neustradamus (Neustradamus)
Tuesday 16 April, 2019 21:49:54

Avez-vous trouvé un pare-feu (firewall) pour l'IPv6 ?

interdif (interdif)
Wednesday 17 April, 2019 00:10:49

bonjour,

meme soucis, ipv4 déconne méchamment en bridge, ipv6 ok, la gateway free repond au ping ... mais pas internet

il semble que la freebox player soit au moins en partie responsable du soucis, si on ne branche pas le player la connection semble tenir au moins un certain temps, une foi le player connecté c'est entre quelques minutes ou heures avant que l'ipv4 tombe en rade...

ça a fonctionné un certain temps normalement, c'est depuis 1 semaine - 10 jours

je pense que c'est peut être lier a la migration de leur coeur de reseau vers ipv6

si un dev passe par la mon dslam est :cvl92-3

il est regrettable que free délaisse de plus en plus ses clients technophile ...

interdif (interdif)
Wednesday 17 April, 2019 00:11:52

oublié : freebox v6 (R2)

Damien (dough29)
Wednesday 17 April, 2019 05:16:38

@Neustradamus : pour ma part j'ai un serveur Proxmox avec une VM pfSense qui fait le boulot.

Neustradamus (Neustradamus)
Wednesday 17 April, 2019 06:31:44

@dough29 : Ce n'est pas une solution réelle, c'est un contournement ^^
Le but n'est pas d'avoir des Freebox passoires (comme actuellement... failles etc)
Et puis je vois mal les gens acheter un serveur pour l'installer et le configurer...

Damien (dough29)
Wednesday 17 April, 2019 09:14:52

C'est clair que pour le lambda devoir ajouter un équipement c'est inconcevable !

Pour moi quand ils passeront en IPV6 natif il y aura forcément une notion de firewall dans le FreeboxOS, je ne vois pas trop comment ils pourraient faire sinon.

Pour ma part, je suis d'hors et déjà prêt à passer en IPV6 natif, mais il faut absolument du 4RD, c'est d'ailleurs dingue le nombre d'entités de l'IT qui ne sont pas encore présentes sur le réseau V6 !

utopik (utopik)
Wednesday 17 April, 2019 17:34:00

Moi aussi j'ai remarqué qu'il y avait un lien de cause à effet lorsque je branche le module TV.
Mais du coup, concrètement, si on veut utiliser la box en bridge et un pfsense derrière, y'a une solution qui permet d'éviter les coupures ?
Car j'ai fini par abandonner et passer en double nat, mais c'est pas une vie :D

interdif (interdif)
Wednesday 17 April, 2019 22:45:08

non, j'ai fait des tonnes de tests avec pfsense, freebsd et linux, meme si pfsense c'est du freebsd packagé on sais jamais ..

j'ai testé avec switch L2 d’autorisé que le vlan 100 vers la tv, d'ici que le player spoof l'ip public on sais jamais

j'ai aussi fait le test de faire transité le vlan 100 a travers mon routeur et de bloque tout les ips sur les range public (la tv transit sur un pool en 192.168.x.x a travers le vlan 100)

d'autres test sensé ou non, quand on est désespéré on compte plus ...

au final NADA !

cela dit le bug est récent pour moi, j'ai l'impression que c'est lier a leur migration du cœur de réseau en ipv6, peut etre que quand le player se connecte il fait basculer la freebox vers le 4rd et provoque le bug, il faut bien voir que seul l'ipv4 lâche, en ipv6 c'est toujours bon ...

il est temps que free communique sur ce bug !

interdif (interdif)
Wednesday 17 April, 2019 22:49:18

sinon pour contourner le problème il existe une solus mais ul faut avoir un serveur dédié avec 2 ipv4 et de l'ipv6, tu fait un tunnel en ipv6 et tu route ton ipv4 de dédié sur ton pfsense ...

si tu as ça a dispo, c'est un hackfix de merde mais ça a le mérite de fonctionné

pas d'autre idée sinon surtout que j'ai beau redémarré la box 2 - 3 fois ça veut pas revenir, il faut repasser en mode routeur 1 ou 2 fois...

Damien (dough29)
Thursday 18 April, 2019 05:10:54

Vous pensez qu'on est déjà en IPV6 natif + 4RD ?

Si c'était le cas on n'aurai plus la possibilité de désactiver V6 non ? Et d'ailleurs j'imagine qu'on pourra désactiver V4 une fois passés en 4RD (!)?

Dans notre problème l'IPV4 se casse la gueule oui et non en fait, on peut toujours ping la gateway !

Neustradamus (Neustradamus)
Friday 19 April, 2019 16:40:25

Attention, il n'y a pas de pare-feu (firewall) en IPv6.

A vous de voter urgemment pour ce bug historique: https://dev.freebox.fr/bugs/task/4110.

interdif (interdif)
Friday 19 April, 2019 16:56:06

Je ne sais pas, je pense que c'est en grande partie sur les routeur et dslam que c est géré, je pense que si on peux avoir un ping sur la gateway ça est justement que la gateway est le soucis, preuve en est que la freebox arrive à communiquer avec le dslam en avec ipv4...

Quand à l histoire de pas pouvoir désactivé la v6 je pense que c est sans rapport, c est pas ton pc ou routeur qui fait le 4rd ou le 6rd, ne plus annoncé l Ipv6 sur ton l'an ou wan ne signifie pas qu'il n exidte pas sur la box ou le dslam.

Quand au fait que free supprime la deactivation de l Ipv6 c est plutot dn rapport à augmenter le traffic en v6 et le réduire en v4, c est sans doute pas sans impact sur les CPU des box, dslam et routeur de faire des tunnel à cette échelle.

Ces avis et suppositions n engage que moi bien entendu.

interdif (interdif)
Friday 19 April, 2019 16:58:44

Pour le firewall en Ipv6 c est une toute autre histoire et je pense que c est totalement hors rapport avec le but de cette tache

interdif (interdif)
Tuesday 23 April, 2019 04:27:34

c'est de pire en pire, maintenant en plus de l'ipv4 qui fonctionne plus du tout en bridge, la tv déconne, le replay et la bulle avec le programme et le résumé sur freeboxtv sont hs (résumé indisponible)

j'ai eu une coupure de courant et le serveur a fait la maj en 4.0.5, le player aussi e crois a fait une mise a jour

il semble que cette maj agave encore les choses, c'est désolant ..............

pour le moment j'ai fait un tunnel ipv6 et je route mon trafic v4 ver un serveur mais c'est pas une vrai solution !

A QUAND UNE INFO DE LA PART DE FREE ??!!!

ag (ag)
Sunday 28 April, 2019 23:23:05

Merci à Damien pour son code ! \o/

Damien (dough29)
Monday 29 April, 2019 07:04:12

C'est vrai que le script est assez efficace mais pour ma part je suis revenu en double NAT pour l'instant...

Je suis quasi prêt pour le Full IPV6 sur mon réseau sauf que le NAT64 c'est pas encore trop ça sur certains sites.

jf garreau (jeffetflo)
Wednesday 8 May, 2019 15:03:13

Même problème ici. La connectivité IPv4 saute sans cesse.

Neustradamus (Neustradamus)
Thursday 9 May, 2019 09:16:47

Il y a un bon moment, il a été demandé la mise à jour de bridge-utils : https://dev.freebox.fr/bugs/task/25749

Ainsi que beaucoup d'autres mises à jour également : https://dev.freebox.fr/bugs/task/22518

D'autres tickets ont été ouverts également (soft/lib) afin de ne pas oublier.

Que ce soit à propos de l'IPv4 ou l'IPv6, etc.

Dnsmasq avec failles de sécurité :
- https://dev.freebox.fr/bugs/task/25751

- https://dev.freebox.fr/bugs/task/27111

- https://dev.freebox.fr/bugs/task/27112

radvd :
- https://dev.freebox.fr/bugs/task/25775

nss-mdns :
- https://dev.freebox.fr/bugs/task/27148

- https://dev.freebox.fr/bugs/task/27149

Rappel, il n'y a pas de :
- Pare-feu (firewall) pour l'IPv6 : https://dev.freebox.fr/bugs/task/4110

- Reverse IPv6 : https://dev.freebox.fr/bugs/task/12749

Damien (dough29)
Thursday 9 May, 2019 11:09:52

Comme quoi avec le temps pas grand chose ne s'arrange, sans compte que sortir une nouvelle box aurait été l'occasion de mettre un bon coup de neuf...

Damien (dough29)
Tuesday 11 June, 2019 15:59:29

https://dev.freebox.fr/bugs/task/22541

Ce ticket vient d'être clôturé "résolu", quelqu'un a des informations ?!

Neustradamus (Neustradamus)
Tuesday 11 June, 2019 18:13:14

De bons tickets ont été clôturés ce jour, même des bons...
Sans doute pour que l'on fasse une création d'un nouveau ticket pour chaque problème, surtout un ticket = un problème, pas plusieurs problèmes dans un ticket.

Damien (dough29)
Tuesday 11 June, 2019 18:27:05

Ben autant passer un ticket à "clos" ok mais ne mettre que "résolu" comme commentaire c'est léger...

Skandev (skalma)
Saturday 6 July, 2019 15:32:05

Bonjour,

Souci toujours présent. Je suis sous pfsense avec la freebox révolution en mode bridge. Même en désactivant le DHCPv6 sur le pfsense, le simple fait de brancher le player en ethernet sur le server et de l'allumer > Perte de connectivité ipv4.

Petit up donc chers développeurs freebox...

mickael H (mickaelh51)
Sunday 13 October, 2019 16:15:31

Bonjour à tous,
aujourd'hui je viens de subir le phénomène ! dés que j'allumais la freebox player je perdais la connexion sur mon routeur pfsense (avec l'option "obtenir une IP en DHCP pour le freebox player en mode bridge" activée ou non).
Je pense avoir trouvé la solution, mais cela implique d'avoir un switch gérant les vlans.

En gros j'ai connecté la freebox V6 sur un port de mon switch et le freebox player sur un autre. Ensuite j'ai créé le vlan 100 (vlan de communication entre la freebox et la TV) et là la TV fonctionne parfaitement sans coupé Internet.
En effet, le fait de "brider" le vlan 100 entre les 2 serveurs, on est sûr que le freebox player n'ira pas prendre l'IP publique attribuée au routeur pfsense.

Je teste encore quelques jours pour voir la stabilité.

PS: pour avoir accès aux appli sur la freebox player, je pense qu'on peut propager le vlan du LAN sur le port pour qu'elle choppe une IP dans le lan et ainsi obtenir l'accès à internet, je testerai.

++

Chargement...