Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie Services locaux → SMB
  • Assignée à Personne
  • Système d'exploitation Tous
  • Sévérité Critique
  • Priorité Normale
  • Basée sur la version 4.3.2
  • Due pour la version Non décidé
  • Date d'échéance Non décidé

FS#34842 - [WINDOWS 10] Bloqué à 99%

Bonjour, j’ouvre une nouvelle tâche pour un soucis Windows 10 (déjà présent pendant la beta d’après certains utilisateurs)
Testé sur Freebox Révolution.

Au moment de la suppression de la plupart des fichiers / dossiers mais aussi lors de certains transferts, l’explorateur reste bloqué à 99% avec 0 octet restant, et impossible d’annuler. Obligé de redémarrer explorer.exe pour enlever le message. Cependant, les transferts sont effectués.
Cela se produit également lors d’un renommage d’un fichier.

Précisions :
Le bug se produit sur tous les PC windows (à jour).
Le disque dur sur la Freebox Révolution est formaté en NTFS (et n’a pas été reformaté depuis la 4.3.0).
Le bug fait planter le processus explorer.exe : si vous supprimez/renommez un fichier local (sur le Bureau par exemple), ça va rester aussi à 99% jusqu’au redémarrage du processus.

Cette tache ne dépend pas d'autre tache

loggoi (loggoi)
vendredi 14 mai, 2021 06:25:04

Il manque des infos dans votre message... Que vient faire la freebox dans votre problème de Windows ?
Vous parlez de fichiers supprimés de la freebox via un partage samba ? mais dans ce cas quel rapport avec ça : " si vous supprimez/renommez un fichier local (sur le Bureau par exemple), ça va rester aussi à 99% jusqu’au redémarrage du processus.” ??

Marios Makassikis (mmakassikis)
vendredi 14 mai, 2021 08:51:53

Bonjour,

Si vous avez un antivirus, est-ce que le problème se produit toujours si vous le désactivez temporairement ?

Vous indiquez que le problème se présente lors de certains transferts. Est-ce que cela concerne les transferts dans les deux sens (Freebox → Windows et Window → Freebox) ?

Lorsque le bug se présente, pouvez-vous vérifier qu’il n’y a pas d’autres processus ayant ouvert le fichier ?
- Démarrer > Exécuter > resmon
- Dans l’onglet “CPU”, indiquez le nom du fichier qui est bloqué dans la troisième section.

Pouvez-vous préciser la version exacte de Windows ? Je n’arrive pas à reproduire le problème sur un Windows 10H2 10.0.19042.985.

lyessi (lyessi78)
vendredi 14 mai, 2021 22:16:55

J’ai le même problème. Cela se produit lorsque l’on active SMBv2 dans freebox OS. Cela fait planter l’explorateur Windows lorsque que l’on tente de renommer, supprimer, déplacer un fichier qui se trouve sur le disque dur de la freebox. Plusieurs personnes ont le problème. Il faudrait revoir le SMBv2. En attendant, je reste en SMBv1. Aucun soucis sur cette version.

abaca20 (abaca20)
mardi 18 mai, 2021 00:16:41

Bonsoir, n’étant pas à mon domicile je ne pourrai qu’effectuer vos demandes qu’en fin de semaine. Toutes mes excuses.
Je peux répondre à certaines questions cependant.

@loggoi : Le problème vient du SMBv2 de la Freebox, avec le partage des disques durs (externes et internes). Si vous voulez, dès que je supprime/renomme/transfère un fichier du disque Freebox, ça bloque à 99% effectué. Et ça ne part jamais. Du coup, si je veux supprimer/renommer/transférer un fichier cette fois sur mon PC (sur mon bureau par exemple), et bien ça va rester aussi à 99% car l’explorateur Windows restera planté, à cause de mon action sur le serveur.
Je n’avais jamais eu ce problème, en SMBv1 ou d’autres serveurs SMBv2.

@mmakassikis : Je n’ai pas lancé d’autres programmes pendant mes transferts mais je ne peux pas vous dire exactement quels processus étaient lancés. Cependant, sur mes ordinateurs j’ai Avast comme antivirus, je testerai en fin de semaine sur un autre ordinateur sans antivirus.
La version de Windows est la dernière en date (PC à jour, pas en version bêta/insider juste la version normale). Mais Windows 10 Pro.

@lyessi78 : C’est exactement ça et c’est clairement mieux expliqué que moi :)

Neustradamus (Neustradamus_)
vendredi 21 mai, 2021 21:52:55

@abaca20: Nous attendons votre retour avec impatience, beaucoup de personnes impactées d’après les commentaires sur Univers Freebox :
- https://www.universfreebox.com/article/486426/free-lance-une-nouvelle-mise-a-jour-des-freebox-revolution-mini-4k-pop-delta-et-one

abaca20 (abaca20)
vendredi 21 mai, 2021 22:24:27

Bonsoir. Je viens apporter quelques précisions :

@mmakassikis :
- J’ai désactivé Avast! pendant la durée de mes transferts : aucun changement.
- Cela concerne les transferts dans les deux sens (Freebox → Windows et Windows → Freebox)
- Aucun processus n’est ouvert pendant le transfert, les fichiers transférés ne sont pas utilisés par d’autres processus.
- Version de Windows : 10.0.19042.985
- Le problème est toujours présent malgré la MAJ Freebox Server v4.3.3.

J’ai cependant un message d’erreur dans l’observateur d’événements (Journaux des applications > Microsoft > Windows > SMBClient), je ne sais pas si ça a un lien mais il est apparu au moment du bug :

Échec de l’établissement d’une connexion réseau.

Erreur : La demande d’E/S a été annulée.

Nom du serveur : FREEBOX_SERVER
Adresse du serveur : [fe80::72fc:8fff:fe9e:fd8e%21]:445
Nom de l’instance : \Device\LanmanRedirector
Type de connexion : Wsk

Conseils : 
 Cela indique un problème au niveau du réseau ou du transport sous-jacent, par exemple avec TCP/IP et non avec SMB. Un pare-feu qui bloque le port TCP 445 ou le port TCP 5445 lors de l’utilisation d’une carte RDMA iWARP peut également provoquer ce problème.
abaca20 (abaca20)
vendredi 21 mai, 2021 22:36:01

Re-
Bonsoir @Neustradamus_ , merci pour l’info :)

J’ajoute (encore) que :
- Le bug se produit en Wi-Fi comme en Ethernet.

Neustradamus (Neustradamus_)
vendredi 21 mai, 2021 22:57:50

Le problème semble être lié à l’IPv6.

Pour s’en assurer, avez-vous essayé en désactivant l’IPv6 de la carte réseau de votre Windows 10 et en restant uniquement en IPv4 ?

abaca20 (abaca20)
samedi 22 mai, 2021 10:36:58

Bonjour,

En désactivant l’IPv6 le problème est toujours présent malheureusement.
Testé en Wi-Fi et en Ethernet, IPv4 et IPv6, sans et avec antivirus. Les erreurs restent les mêmes.

Avec plus d’attention, je découvre 1 erreur et 2 avertissements dans l’observateur d’événements. Dans l’ordre d’apparition :


1) Erreur : (Événement 30804, SMBClient)

Une connexion réseau a été perdue.

Nom de l'instance : \Device\LanmanRedirector
Nom du serveur : \FREEBOX_SERVER
Adresse du serveur : 192.168.1.254:445
Type de connexion : Wsk
InterfaceId : 21

Aide :
ceci indique que la connexion du client au serveur a été perdue.

Des déconnexions fréquentes et inattendues lors de l'utilisation d'un adaptateur RoCE (RDMA sur Converged Ethernet) peuvent être le signe d'une configuration réseau incorrecte. La carte RoCE requiert le contrôle de flux prioritaire (PFC) pour être configurée sur chaque hôte, commutateur et routeur du réseau RoCE. Une configuration incorrecte du PFC entraîne des pertes de paquets, des déconnexions fréquentes et une diminution des performances.

2) Avertissement (Événement 30805, SMBClient)

Le client a perdu sa session au serveur.

Erreur : La connexion de transport est maintenant déconnectée.

Nom du serveur : \FREEBOX_SERVER
ID de session : 0x2

Aide :
Si le serveur est un serveur de fichiers du cluster de basculement Windows, ce message s’affiche lorsque le partage de fichiers passe d’un nœud du cluster à un autre. Un anti-événement 30806 doit également se produire pour indiquer que la session sur le serveur a été rétablie. Si le serveur n’est pas un cluster de basculement, il est probable que le serveur était auparavant en ligne et qu’il est à présent inaccessible sur le réseau.

3) Avertissement (Événement 30807, SMBClient)

La connexion au partage a été perdue.

Erreur : La connexion de transport est maintenant déconnectée.

Nom du partage : \FREEBOX_SERVER\Disque dur
ID de session : 0x2
ID d’arborescence : 0x2

Aide :
Si le serveur est un serveur de fichiers du cluster de basculement Windows, ce message s’affiche lorsque le partage de fichiers passe d’un nœud du cluster à un autre. Un anti-événement 30806 doit également se produire pour indiquer que la session sur le serveur a été rétablie. Si le serveur n’est pas un cluster de basculement, il est probable que le serveur était auparavant en ligne et qu’il est à présent inaccessible sur le réseau.
lyessi (lyessi78)
samedi 22 mai, 2021 12:03:16

Pour ma part, le problème semble être réglé depuis la maj 4.3.3.

@abraca20 As-tu réessayer après la mise à jour 4.3.3 ?

abaca20 (abaca20)
samedi 22 mai, 2021 15:56:40

@lyessi oui j’avais précisé “- Le problème est toujours présent malgré la MAJ Freebox Server v4.3.3. " :)

La démarche exacte que je fais :

Je vais sur le Disque dur Freebox via l’explorateur Windows en SMB (que j’ai ajouté en faisant “Connecter un disque réseau”)
Je supprime un fichier, et dès la 1ère ou 2e suppression, l’explorateur se bloque à 99%.
Et si j’essaye de renommer un fichier après ce blocage, c’est tout l’explorateur qui se fige et qui redémarre.
Sur les 2 disques de la freebox (Disque interne en ext4 et le disque externe en NTFS).

Par contre (en rapport au 2e commentaire) ces disques n’ont pas été re-formatés depuis la màj en 4.3.0.

abaca20 (abaca20)
dimanche 23 mai, 2021 14:01:37

Bonjour,

Après d’autres tests je reviens vous dire que :

Il n’y a aucun bug si on utilise cmd. Je m’explique :
Si je veux renommer (ren), copier (copy), déplacer (move) un fichier mais VIA cmd.exe (l’invite de commandes), ça fonctionne parfaitement.

Je n’ai d’ailleurs aucun message d’erreur dans l’observateur d’événements.

Via l’explorateur Windows par contre, toujours aucun changement. C’est le plus embêtant.

Marios Makassikis (mmakassikis)
lundi 24 mai, 2021 07:30:20

@abaca20
Merci pour ces tests.
Le comportement différent entre cmd.exe et explorer.exe laisse penser que ce dernier n’exécute pas les opérations de la même manière. Pourriez-vous m’indiquer la MAC de votre freebox serveur afin que je puisse regarder les logs ?

Marios Makassikis (mmakassikis)
lundi 24 mai, 2021 08:42:31

@abaca20
Pouvez-vous m’envoyer le résultat de la commande PowerShell Get-SmbClientConfiguration ?

De plus, pouvez-vous tester si la désactivation du MultiChannel corrige le problème avec explorer ?
Pour cela, il faut ouvrir un invite powershell en tant qu’administrateur et saisir la commande suivante:

<code>

Set-SmbClientConfiguration -Enable-Multichannel $False

</code

abaca20 (abaca20)
lundi 24 mai, 2021 20:49:19

@mmakassikis : Bonjour,

- Pour les infos de ma Freebox (MAC, Numéro de série...) : https://pastebin.com/nW5tLFFu

- La désactivation du MultiChannel n’a rien changé malheureusement, toujours le même bug. D’ailleurs, le code n’était pas bon il fallait faire :

Set-SmbClientConfiguration -EnableMultiChannel:$False
abaca20 (abaca20)
lundi 24 mai, 2021 20:51:54

Pour la commande demandée (j’avais mal lu le premier message) :)
(J’ai réactivé le MultiChannel puisqu’il l’était par défaut)

ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : True
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : True
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8
Fouggee (Fouggee)
jeudi 27 mai, 2021 16:57:20

Bonjour à tous,
Je viens confirmer que j’ai moi aussi les mêmes problèmes en smbv2 avec les partages de serveur freebox.
Les tâches de copie suppression etc restent bloquées à 99%, Explorer plante et redémarre fréquemment.
Par contre ça règle bien les problèmes de mappage de lecteurs réseau qui sont immédiatement disponibles et accélère l’affiche des dossiers.
Si je repasse en smbv1, j’ai de nouveau les problème de mappage de lecteur, freebox-serveur s’affiche dans le voisinage réseau mais l’accès est impossible.
Je constate aussi depuis des problèmes avec le ftp, j’ai ouvert un autre ticket à ce sujet.
Je précise que tout fonctionnait pour moi correctement avant 4.3.2 et 4.3.3 ne régle pas le problème. Merci.

Lespiler Jean (Prax)
jeudi 3 juin, 2021 17:13:38

Même souci pour moi sur Windows 10 21H1

Build 19043.985 Windows Feature Experience Pack 120.2212.2020.0

Je précise que je suis en beta sur le firmware du Server Delta puisque bêta-testeur de l’application Freebox Connect.

Bloqué à 99% sur mes transferts. Obligé de redémarrer l’explorer.

J’ai trouvé l’erreur ci-dessous dans l’Observateur d’Evènements Système mais je ne sais pas trop s’il y a un lien :

Le serveur n’a pas pu se lier au transport \Device\NetBT_Tcpip_{857F84B5-E031-4D31-9ED1-30D44EE887B0} car un autre ordinateur du réseau porte le même nom. Le serveur n’a pas pu démarrer.

Marios Makassikis (mmakassikis)
vendredi 4 juin, 2021 07:10:45

@Lespiler Jean
Dans quelle catégorie de l’observateur d’événement cette erreur est-elle enregistrée ?

Pouvez-vous confirmer qu’il n’y a pas de doublons sur les nom NetBIOS sur votre réseau local ?

Lespiler Jean (Prax)
dimanche 13 juin, 2021 10:55:34

@Marios

Désolé pour mon retour très tardif !

L’erreur était dans la rubrique “Journaux windows” » “Système” et pas de doublon sur mon réseau.

Cela semble résolu pour moi sur le firmware 4.3.5 du Server :-)

Bonne journée !

Marios Makassikis (mmakassikis)
lundi 14 juin, 2021 06:59:31

@Lespiler Jean
Je suis content que cela fonctionne pour vous, mais je suis aussi embêté: il n’y a pas de changement au niveau SMB entre les firmware 4.3.3 et 4.3.5. Donc il a autre chose qui a fait que cela fonctionne à présent (reboot de la box ? reboot du PC ?)

@abaca20
D’après mes recherches, le blocage à 99% est un problème qui peut également se produire avec Samba en guise de server mais aussi Windows. J’ai pu lire notammenent que cela peut être lié à la valeur par défaut du SessionTimeout. Pourriez-vous tester si changer ce paramètre (de 60 à 600 par exemple) change le comportement chez vous ?

Lespiler Jean (Prax)
lundi 14 juin, 2021 07:32:40

@Marios

Mon PC est reboot tous les jours et la box depuis 2 jours. La résolution de ce problème chez moi reste un mystère.

Je garde un œil ouvert si jamais cela se représente et vous tiendrai informé.

Bonne journée :-)

abaca20 (abaca20)
lundi 14 juin, 2021 15:27:36

@mmakassikis Aucun changement malgré le SessionTimeout à 600. Avec la màj 4.3.5...

Neustradamus (Neustradamus_)
jeudi 24 juin, 2021 11:27:26

@ tous : Quelle est la situation de ce bug en 4.3.6 ?

Chargement...