Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie Services locaux → SMB
  • Assignée à Personne
  • Système d'exploitation Freebox Server V8 (Pop)
  • Sévérité Moyenne
  • Priorité Normale
  • Basée sur la version 4.3.0
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par Tehoden (Tehoden) - 24/04/2021
Dernière édition par Anisse Astier (aastier) - 26/04/2021

FS#34655 - Bug propriétés à 0 + bug d'accès VLC en SmbV2 (FreeboxOS 4.3.0)

Bonjour,
Je faisais partie des beta testeurs et j’ai échangé plusieurs mails avec Mr Makassikis à ce sujet. je vais essayer d’être le plus clair possible. J’ai un disque de 5 To, en NTFS, connecté sur le serveur pop (sur l’Usb3 et le disque est USB3 aussi). Le disque est neuf, acheté en Janvier dernier, un peu avant le début de la béta. J’ai constaté que, sur certains répertoires (ceux avec beaucoup de fichier), si je fais un clic droit sur un fichier, la fenêtre des propriétés affiche un poids de 0Ko et aucune date de création/modification:

nsm09.casimages.comimg2021042421042408501917398417385462.jpg

Dans ce même répertoire, certains affichent correctement la fenêtre des propriétés et certains, comme l’image ci-dessus, sans rien.
Si on tente de parcourir le répertoire en question, par la commande dir en fenêtre CMD, le comportement est également très bizarre. une fois dans le répertoire, si je fais simplement dir, tous les fichiers du répertoire sont trouvés mais pas par ordre alphabétique. Ils sont bizarrement classés. Ils ont l’air (c’est à dire la majorité d’entre eux) d’être par ordre alphabétique mais pas du tout. Tous ceux qui sont pas bien “classés” sont ceux qui présente le bug de la fenêtre de propriétés. j’ai tenté toutes les options de la commande dir mais ça reste pas dans le bon ordre.
De plus, si, sur un fichier présentant le bug de la fenêtre des propriétés, je tente de faire un dir débutdunomdufichier*.*, là, la commande dir me répond que le fichier est inexistant. Résultat étonnant car un dir simple l’a pourtant bien “trouvé”, il est listé. Alors certes, pas au bon endroit dans l’ordre alphabétique mais il est là.

Bug lié à tout ça : Si dans VLC par exemple (depuis téléphone Android ou le lecteur freebox pop), je tente l’accès sur le répertoire avec ce bug, VLC me répond que, tenez vous bien, le répertoire est vide! alors qu’il contient plus de 200 fichiers.

Je vérifie le disque, histoire qu’il ne soit pas défectueux. Je branche le disque sur mon pc puis je le partage sur mon réseau (mon pc a bien smb V1 de désactivé bien sûr et tous les VLC utilisés ont l’option “préférer smbv1” de décochée également). Et la, tout fonctionne parfaitement, tous les répertoires sont biens listés par VLC, du téléphone, de la freebox tout ... impec. Le bug de la fenêtre des propriétés à 0 disparait. Les commandes dir fonctionnent parfaitement. Le disque n’est donc pas en cause.

Une fois le disque rebranché sur la freebox, le bug est de retour. Je constate que n’importe quel répertoire dépassant les 30 fichiers présente ces bugs (mais ce n’est peut être pas pile ce nombre à partir duquel le bug se présente mais j’ai pas mieux, j’ai soit des répertoires à moins de 30 fichiers et la aucun souci ou j’ai beaucoup plus de 30, genre 80-100 voir plus de 200 fichiers, où la le bug est présent) :

- Des fichiers avec fenêtre de propriétés à 0
- exploitation par dir en fenêtre de commande CMD bugée
- VLC ne trouve rien dans ces répertoires, il les voit vide

J’ai refais plusieurs mails à Mr Makassikis mais sans réponses cette fois. J’ai pu voir qu’on était plusieurs à rencontrer des bugs assez similaires (avec d’autre logiciels que VLC). Je pense qu’il reste un bug, lié au nombre de fichiers contenus (ou bien tout autre chose mais il reste un bug, assez gênant car perturbe l’utilisation de VLC).

En espérant avoir une réponse cette fois, sinon je ferais un ticket peut être indépendant histoire de remonter le souci.

Merci beaucoup @ bientôt. Tehoden.

Cette tache ne dépend pas d'autre tache

Tehoden (Tehoden)
samedi 8 mai, 2021 21:01:06

Bonjour bonjour :), un petit mot pour dire que depuis la dernière mise à jour, le bug est toujours présent et surtout, avec la dernière version, la connexion VLC sur le disque dur partager du serveur pop n’est plus du tout possible (en smb v2). Que se soit VLC sur mon portable, depuis le player pop ou la version UWP Microsoft, au moment de la saisie du user/mot de passe, l’authentification est refusée, la fenêtre de saisie du user/mot de passe réapparaît et impossible de se connecter et parcourir le disque.

Neustradamus (Neustradamus_)
jeudi 1 juillet, 2021 10:36:33

@Tehoden : Avez-vous toujours le bug de “propriétés à 0” ainsi que vos autres bugs avec Freebox OS 4.4.0 ?
En gros, quels sont les bugs à ce jour ?

Avez-vous aussi le bug “fenêtre bloquée à 99%” ?
Si oui il faudrait l’indiquer ici : https://dev.freebox.fr/bugs/task/34842.

Afin que @mmakassikis puisse faire le nécessaire.

Merci d’avance.

Tehoden (Tehoden)
jeudi 1 juillet, 2021 15:15:51

Bonjour ..
merci pour votre message et la prise en compte de ce souci :). j’ai effectué la mise à jour 4.4.0 hier soir. J’ai connu un reboot sauvage ce matin, sans raison. Pour le souci de la fenêtre des propriétés à 0, elle est malheureusement toujours d’actualité.

Concernant le blocage à 99%, personnellement, et ce depuis le tout début de la beta smbV2, je n’ai jamais connu ce blocage. J’ai un doute (et j’ai du mal à reproduire et à le diagnostiquer correctement) sur un bug qui concerne la copie d’un répertoire complet. Une fois copié, quelques temps après la copie, la box devient instable. Est-ce réellement lié à la copie, je n’en suis pas sûr.

Pour résumé, bug en cours : la fenêtre de propriété à 0
Bug suspecté : instabilité sur une copie de répertoire.

Les connexions VLC sont fonctionnelles.

Voilà merci.
Cordialement, Tehoden.

Neustradamus (Neustradamus_)
jeudi 1 juillet, 2021 17:00:42

@Tehoden : Je suis un client comme vous, mais il faudrait que @mmakassikis puisse voir ce ticket...
Pourriez-vous quand même lui dire dans le ticket qu’il suit déjà : https://dev.freebox.fr/bugs/task/34842 avec le lien vers celui-ci ?
Il n’est pas du tout apparu dans ce celui-ci...

Neustradamus (Neustradamus_)
mercredi 22 septembre, 2021 05:33:53

En 4.5.0, le problème est toujours là ?

Tehoden (Tehoden)
lundi 27 septembre, 2021 08:23:50

Bonjour,
je viens pour préciser qu’effectivement, j’ai testé hier et le souci est toujours présent. Je parle uniquement du souci concernant la fenêtre des propriétés à 0. J’ai mis un peu de temps à répondre car mon pc principal n’est plus sous Windows, uniquement mon pc portable, qui lui est bien à jour en 21h2. Le bug est toujours présent donc sur ce dernier. C’est avec ce pc portable que j’avais réalisé les captures Wireshark que j’ai envoyé à Mr Makassikis.

Pour mon pc principal, ce dernier est maintenant sous Linux Mint et j’avoue ne pas constater le moindre souci ... il y a de forte chance que cela soit lié à Windows (un bug sous jacent côté Windows qui provoquerai cela).

merci beaucoup.

Chargement...