Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Close
  • Type de tâche Anomalie
  • Catégorie WAN → Fibre
  • Assignée à Personne
  • Système d'exploitation Freebox Server V8 (Pop)
  • Sévérité Critique
  • Priorité Normale
  • Basée sur la version 4.2.1
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par acidul (acidul) - 23/07/2020
Dernière édition par Maxime Bizon (mbizon) - 06/08/2020

FS#31218 - Mode bridge -> connection internet HS

Bonjour,

j’utilise un routeur wifi TP-LINK branché sur la freebox server pop (cette information est juste pour donner le contexte),
et j’ai eu le malheur de changer le mode “router” du server pop au mode “bridge”, via http://mafreebox.freebox.fr .
Les conséquences :
- plus de connection internet, ni en ethernet, ni en wifi free, ni en wifi TPLINK (qui est branché en ethernet sur la box).
- et impossible de me reconnecter sur http://mafreebox.freebox.fr pour faire machine arriere.

Merci de m’aider à régler ce problème qui est pour moi critique !
j’ai aussi cherché comment faire un hard reboot du server pop, mais je n’ai pas trouvé...

Thanks

Close par  Maxime Bizon (mbizon)
Thursday 6 August, 2020 08:30:56
Raison de clôture :  Résolu
Commentaires supplémentaires de clôture :  en 4.2.3

le bug au moment du passage routeur => bridge sera corrigé dans la 4.2.4

Cette tache ne dépend pas d'autre tache

Neustradamus (Neustradamus_)
Thursday 23 July, 2020 22:56:19

@acidul: Avez-vous essayé de passer par https://subscribe.free.fr/login/ ?
Ma Freebox → Configurer mon routeur Freebox → État du routeur → Mettre "actif" au lieu d'"inactif" → Valider
→ Rebooter le boîtier Server

S'il est déjà "actif", le mettre en "inactif" puis de valider puis remettre "actif" puis valider puis rebooter ?

acidul (acidul)
Friday 24 July, 2020 05:40:15

Merci pour votre réponse mais lorsque je vais dans "Configurer ma Freebox",
j'ai ce message :
Pour configurer votre Freebox, vous devez vous rendre sur mafreebox.freebox.fr depuis votre connexion Free

J'ai aussi essayé de faire des choses via l'application Freebox connect, j'accède bien à la pop, mais à part le redémarrer je ne peux pas faire grand chose d'autre.

Une autre idée ?

ApiStart (ApiStart)
Friday 24 July, 2020 07:13:53

Bonjour,

Regardez dans les commentaires ici : https://dev.freebox.fr/bugs/task/31158

Bonne journée ;)

acidul (acidul)
Friday 24 July, 2020 08:01:05

Bonjour @ApiStart,

merci pour le lien, je comprends que le mode bridge ne fonctionne pas pour la pop comme attendu, correct ?
j'ai eu le support 3244 au téléphone ce matin qui a pu rétablir le wifi de la freebox, qui m'a permis de naviguer de nouveau via Wifi.
En revanche, la navigation depuis les ports ethernet était toujours KO de mon côté.
Il y a donc bien un problème dans ce mode bridge.

Nous avons fait un reset usine, pour cela il faut
- débrancher le server
- rebrancher
- lorsque le logo free apparait, appuyer sur la fleche de droite
- puis sélectionner Paramètre d'usine pour restaurer les paramètres de la box.

Suite à cela, j'ai pu retrouver la navigation depuis les ports ethernet.

Merci beaucoup au support 3244
et bon courage au dev pour fixer ce problème.

Bonne journée à tous

ApiStart (ApiStart)
Friday 24 July, 2020 08:34:49

Effectivement, le mode bridge est HS, en IPv4 et IPv6.
Il est toujours possible de faire du double NAT (même si ce n’est pas propre) avec la DMZ en IPv4 et d’avoir les routes en IPv6 en mode routeur.

J’ai essayé avec la version 4.2.2 et le mode bridge ne fonctionne toujours pas, il faut surement attendre la 4.2.3 :p

BingoN (BingoN)
Friday 24 July, 2020 17:29:14

en v4.2.2 livebox pop fibre fraichement activé:
- fonctionne parfaitement en mode router avec la fibre
- activation du mode bridge - reboot de la box, passage par les étapes 1-2-3a b jusqu'à e, puis retour à Etape 2, et message "en attente connexion ADSL" (la connexion réelle est par fibre).La box ne fournit pas d'IP et n'est pas visible du support (3244).
- le bug semble donc être une confusion de la box pop sur le mode à activer (DSL/Fibre) lorsqu'elle est passée en mode router.

- contournement : la réinitialiser (cf. procédure décrite par acidul) et la garder en mode bridge avec DMZ.

bon courage pour le débugging !

manu512 (manu512)
Saturday 25 July, 2020 08:20:35

Comme tout le monde. Mode Bridge HS...
Le HelpDesk 'de base' pas formé, le site assistance pour la POP pas mis a jour.
Heureusement, il y a une cellule POP accessible que par le 3244 qui est payant je le rappel.

Moyen moyen je trouve.

acidul (acidul)
Saturday 25 July, 2020 08:49:21

J'ai eu hier le support au téléphone pour 2 sujets différents et à chaque fois la personne était compétente et à l'écoute.

Et pour ce qui est du prix j'ai appelé depuis ma ligne mobile Free, c'était donc gratuit, donc pas concerné...

christophe yayon (cyayon)
Sunday 26 July, 2020 05:54:32

Ce serait quand même bien si on pouvait simplement mettre un route statique dans la freebox.
Cette fonctionnalité est réclamée depuis de nombreuses années !
De cette manière, on pourrait rester en mode routeur sans pour autant faire du double NAT...
Aller FREE, svp...

ApiStart (ApiStart)
Sunday 26 July, 2020 09:30:49

Bonjour,

Il me semble que la raison pourquoi Free n’ajoute pas la possibilité d’ajouté des routes IPv4 statiques est que la Freebox ou le réseau de free utilise beaucoup de plage d’adresse IP privé.

christophe yayon (cyayon)
Sunday 26 July, 2020 10:10:25

Je ne comprends pas cette réponse...
La route serait sur l’interface interne de la freebox, pas sur la patte wan bien sûr ...

Thomas (thomasnet)
Tuesday 28 July, 2020 14:19:29

J'ai aussi eu le même problème: la box entière se freeze environ 10 sec après le boot en mode bridge - plus d'accès à l'interface web, les boutons sur la face du Server ne font rien, et le 3244 a pu la reset à distance pendant que la box était encore joignable.

Neustradamus (Neustradamus_)
Tuesday 28 July, 2020 17:29:39

Avez-vous regardé la date de génération du certificat de Freebox OS en https ?
Est-ce bon ?
Il y a des problèmes à ce niveau là car il ne se met pas à jour en mode bridge.

david.keller (david.keller)
Friday 31 July, 2020 10:44:47

Impossible d'avoir une connectivité réseau en bridge sur mon setup.

Voici les étapes suivies:

1) déballage
2) connexion à la fibre + connexion au routeur perso
3) allumage
4) connexion via réseau wifi
5) changement du mdp mafreebox.freebox.fr
6) activation du mode bridge via mafreebox.freebox.fr

→ La box reboot mais se reste aux réglages d'usines (mode routeur à nouveau, mot de passe mafreebox.freebox.fr perdu)

Je recommence depuis l'étape 4.

→ Pour le même résultat.

Je recommence encore depuis l'étape 4.

→ Cette fois le wifi n'est plus actif après le reboot (marqué comme non-configuré sur le LCD).
→ Mais mon routeur ne peut pas à résoudre l'adresse MAC la gw de FREE atteignable via A.B.C.254 (avec A.B.C.X qui correspond à mon ip publique).
→ A ce stade, les touches en façade ne répondent plus, mais l'heure affichée sur le LCD est bien incrémentée.

→ Après plusieurs reboot en restant appuyé sur les touches de façade, le boot menu est proposé sur le LCD: a) normal, b) rescue, c) factory reset.

J'ai opté pour c).

Puis j'ai configuré mon routeur en DMZ.

david.keller (david.keller)
Friday 31 July, 2020 10:46:45

(Freebox v8 (r1), firmware version 4.2.2)

Thibault HUTTIN-PASSERON (SwHawk)
Wednesday 5 August, 2020 13:14:21
  • Champ changé: Pourcentage achevé : (100% → 0%)

La freebox pop est effectivement capable de passer en mode bridge sans planter.
Toutefois, une fois le mode bridge activé, impossible d’obtenir l’adresse IP publique de la Freebox par DHCP, et impossible de la mettre en statique non plus, quel que soit le port du switch utilisé (2.5 Gbps, 1Gbps, 1Gbps+POE).

Inclus : log NetworkManager d’un laptop connecté en direct sur la Freebox :
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0948] device (enp0s25): carrier: link connected
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0964] device (enp0s25): state change: unavailable → disconnected (reason ‘carrier-changed’, sys-iface-state: ‘managed’)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0975] policy: auto-activating connection ‘Connexion filaire 1’ (f4120a1f-95f0-35b9-8115-a0ff88d16122)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0984] device (enp0s25): Activation: starting connection ‘Connexion filaire 1’ (f4120a1f-95f0-35b9-8115-a0ff88d16122)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0985] device (enp0s25): state change: disconnected → prepare (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.0990] device (enp0s25): state change: prepare → config (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.1061] device (enp0s25): state change: config → ip-config (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:53:59 zbook-17-fedora NetworkManager[1783]: <info> [1596632039.1065] dhcp4 (enp0s25): activation: beginning transaction (timeout in 45 seconds)
août 05 14:54:16 zbook-17-fedora NetworkManager[1783]: <info> [1596632056.8904] device (enp0s25): state change: ip-config → ip-check (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:54:16 zbook-17-fedora NetworkManager[1783]: <info> [1596632056.9060] device (enp0s25): state change: ip-check → secondaries (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:54:16 zbook-17-fedora NetworkManager[1783]: <info> [1596632056.9062] device (enp0s25): state change: secondaries → activated (reason ‘none’, sys-iface-state: ‘managed’)
août 05 14:54:16 zbook-17-fedora NetworkManager[1783]: <info> [1596632056.9076] policy: set ‘Connexion filaire 1’ (enp0s25) as default for IPv6 routing and DNS août 05 14:54:16 zbook-17-fedora NetworkManager[1783]: <info> [1596632056.9077] device (enp0s25): Activation: successful, device activated.
août 05 14:54:44 zbook-17-fedora NetworkManager[1783]: <warn> [1596632084.5964] dhcp4 (enp0s25): request timed out
août 05 14:54:44 zbook-17-fedora NetworkManager[1783]: <info> [1596632084.5970] dhcp4 (enp0s25): state changed unknown → timeout

christophe yayon (cyayon)
Wednesday 5 August, 2020 13:15:31

@Thibaut, as-tu installé la 4.2.3 ?

ApiStart (ApiStart)
Wednesday 5 August, 2020 13:19:24

Bonjour,

Comportement idem pour moi en 4.2.3. Que ça soit en IPv4 et l’adresse IPv6 local de la Freebox disparait toujours comme la dernière fois.

Maxime Bizon (mbizon)
Wednesday 5 August, 2020 13:37:25

@SwHawk

je viens de voir qu'il y a un petit bug, quand on change la configuration en mode bridge, cela ne fonctionne pas

par contre cela fonctionne bien si la box est en mode bridge au moment ou elle démarre.

Thibault HUTTIN-PASSERON (SwHawk)
Wednesday 5 August, 2020 13:37:46

@chaton : oui, c'était bien après la maj en 4.2.3...
Par contre, après un reboot du server pop, j'ai finalement réussi à obtenir l'IP publique en DHCP. Donc je pencherai plus pour un mauvais restart du serveur DHCP lors du passage en bridge puisqu'après le reboot le bridge est fonctionnel. Je n'ai pas encore testé l la connectivité IPv6, mais comme il n'y a aucun changement de ce côté là, je ne vois pas pourquoi il y aurait un souci.

Je teste et je reviens dire ce qu'il en est

christophe yayon (cyayon)
Wednesday 5 August, 2020 13:40:38

@maxime, donc en gros, il faut rebooter 2 fois si l'on passe du mode routeur au mode bridge. C'est bien cela ? merci

Maxime Bizon (mbizon)
Wednesday 5 August, 2020 13:42:40

"Par contre, après un reboot du server pop, j'ai finalement réussi à obtenir l'IP publique en DHCP. Donc je pencherai plus pour un mauvais restart du serveur DHCP lors du passage en bridge puisqu'après le reboot le bridge est fonctionnel. Je n'ai pas encore testé l la connectivité IPv6, mais comme il n'y a aucun changement de ce côté là, je ne vois pas pourquoi il y aurait un souci. "

je confirme ce problème; il faut démarrer en mode bridge, on corrigera ça pour que la transition fonctionne dynamiquement

j'ajoute que le mode bridge est supporté uniquement sur le port 2.5Gbit/s

ApiStart (ApiStart)
Wednesday 5 August, 2020 13:46:13

Ce qui expliquerais pourquoi il ne fonctionne pas chez moi. Tempi, ça attendra ce soir le temps de bouger le câble.

Le redémarrage de la Freebox en mode bridge règle aussi le problème de l’IPv6 ?

Maxime Bizon (mbizon)
Wednesday 5 August, 2020 13:49:19

l'ipv6 fonctionne bien en mode bridge oui, le bug affecte ipv4 et ipv6

Thibault HUTTIN-PASSERON (SwHawk)
Wednesday 5 August, 2020 13:49:36

Bon désolé pour les fautes dans le précédent com' (il fallait lire cyayon et pas chaton, mais mon téléphone en a décidé autrement)...

Donc ça semble bien être un souci uniquement lors du passage en mode bridge (les scripts qui sont mal invoqués ?).

Je viens de tester l'IPv6, c'est fonctionnel, ce qui est quand même mieux quand on veut regarder la télé avec le player.

@mbizon, effectivement, je n'ai pas pensé à retester sur les autres ports, puisque le 2.5Gbps fonctionnait. C'est quelque part dommage qu'on ne puisse d'ailleurs utiliser qu'un seul des 3 ports, car au final avec du LACP on pourrait atteindre 4.5Gbps de connexion et se rapprocher des 5Gbps effectivement offerts par la pop... Mais bon, on va dire que 2.5Gbps c'est déjà pas si mal...

Maxime Bizon (mbizon)
Wednesday 5 August, 2020 13:54:37

LACP c'est du hashing par MAC ou IP pour faire le load balancing

et dans les 2 cas ils sont constants (en mode IPv4), car tout est envoyé entre la box et son next hop qui est votre routeur. Du coup il n'y aurait qu'un port utilisé, meme dans un groupe LACP

Chargement...