Freebox Player (Revolution / V6)

  • État Nouveau   Réouverte
  • Type de tâche Anomalie
  • Catégorie Lecteur multimédia
  • Assignée à Personne
  • Système d'exploitation
  • Sévérité Haute
  • Priorité Normale
  • Basée sur la version 1.1.6
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
  • Votes 0
  • Privée Non
Concerne le projet: Freebox Player (Revolution / V6)
Ouverte par adrenochrome (adrenochrome) - 11/04/2012
Dernière édition par Arnaud Vrac (rawoul) - 13/02/2013

FS#9953 - fichier AVI qui ne demarre pas

J’ai un fichier avi qui, lorsque je le demarre via le player de la freebox, produit un ecran noir sans aucun message d’erreur
Ni la video ni l’audio ne “demarrent” La barre de progression indique “–:–:– / 00:57:31”

je peux acceder au menu (fiche allocine / fmt de la video / ...)

vlc sous linux lit parfaitement le fichier

le bug ne provient pas du nommage du fichier : j’en ai un autre dont l’identation change d’un seul caractere et qui passe tres bien (les seules differences significatives sont :
Writing application : VirtualDubMod 1.5.10.2 (build 2542/release)
Writing library : VirtualDubMod build 2542/release
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : 1
)

si besoin est, je peux decouper les premiers mo en m’assurant que le bug est tjs present

voici les donnees mediainfo du fichier qui pose probleme :

Format : AVI
Format/Info : Audio Video Interleave
File size : 405 MiB
Duration : 57mn 31s
Overall bit rate : 984 Kbps
Writing application : Lavf52.33.0

Video
ID : 0
Format : MPEG-4 Visual
Format profile : Simple@L3
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 57mn 31s
Bit rate : 851 Kbps
Width : 624 pixels
Height : 352 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.155
Stream size : 350 MiB (86%)
Writing library : XviD 1.2.1 (UTC 2008-12-04)

Audio
ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Codec ID : 55
Codec ID/Hint : MP3 Duration : 57mn 31s
Bit rate mode : Constant
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 52.7 MiB (13%)
Alignment : Aligned on interleaves
Interleave, duration : 480 ms (12.00 video frames)
Interleave, preload duration : 25920 ms
Writing library : LAME3.98r
Encoding settings : -m s -V 4 -q 2 -lowpass 17 -b 128

Cette tache ne dépend pas d'autre tache

Arnaud Vrac (rawoul)
mercredi 13 février, 2013 17:17:39

Pouvez-vous envoyer le fichier qui ne fonctionne pas ? Merci

adrenochrome (adrenochrome)
mercredi 13 février, 2013 18:25:20

j’ai decoupe les 20 premier Mo du fichier :
http://dl.free.fr/o5WWoeGPi (password=9953)

a noter que par rapport a la signalisation d’origine, la duree totale n’est plus indiquee

le comportement du troncon est le meme qu’avec le fichier complet que je pourrais uploader integralement si besoin est

Jipen (Jipen)
dimanche 17 mars, 2013 21:37:19

Bonjour,
Même symptôme que décrit ci-dessous pour toutes mes vidéos .MOV de mon reflex Canon encodées en H264.
L’écran reste désespérément noir, la longueur du fichier est bien affichée sur la barre
de progression, mais rien ne se passe.
Les vidéos sont bien lues avec les pack codec et avec VLC.
Version du player : 1.2.5
Caractéristiques des flux vidéo et audio :
Flux 0
Type : Vidéo
Codec : H264 - MPEG-4 AVC (part 10) (avc1), AVC (Baseline@L5.0)(1 RefFrames)
Langue : English
Résolution : 1920×1080 (16/9)
Débit d’images : 25 im/s
Format décodé: Planar 4:2:0 YVU

Caractéristiques détaillées du flux vidéo :
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : Baseline@L5.0
Paramètres du format, CABAC : Non
Paramètres du format, RefFrames : 1 image
Paramètres du format, GOP : M=1, N=12
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 36s 320ms
Débit : 45,0 Mb/s
Largeur : 1 920 pixels
Hauteur : 1 080 pixels
Largeur originale : 1 088 pixels
Format à l’écran : 16/9
Format à l’écran d’origine : 16/9
Type d’images/s : Constant
Images par seconde : 25,000 Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrominance : 4:2:0
Profondeur des couleurs : 8 bits
Type de balayage : Progressif
Bits/(Pixel*Image) : 0.868
Taille du flux : 195 Mio (97%)
Langue : Anglais
Date d’encodage : UTC 2013-03-09 13:18:02
Date de marquage : UTC 2013-03-09 13:18:02
Coordonnées de chromaticité : BT.709
Caractéristiques du transfert : BT.709
Coefficients de la matrice : BT.601

Flux 1
Type : Audio
Codec : PCM S16 LE (sowt)
Langue : English
Canaux : Stéréo
Fréquence d’échantillonnage: 48000 Hz
Bits par échantillon : 16

Je peux fournir un exemple de vidéo qui ne passe pas.
Merci de votre aide.

adrenochrome (adrenochrome)
vendredi 22 mars, 2013 18:38:56

@Jipen
ce n’est manifestement pas le même problème puisque comme indiqué dans mon dernier post la durée n’est plus affichée
de plus ce ne sont pas les mêmes conteneurs (avi VS mov) ni les mêmes codecs video (xvid VS h264) ni les mêmes codecs audio (mp3 VS pcm)
pour une meilleur visibilité de ton problème je pense que tu devrais créer un thread dédié

@Arnaud Vrac
symptomes inchanges avec la 1.2.6 :(

adrenochrome (adrenochrome)
mercredi 24 avril, 2013 23:32:55

@Arnaud Vrac
probleme inchange avec la 1.2.7 :(

Arnaud Vrac (rawoul)
mardi 14 mai, 2013 14:43:21

@adrenochrome: pour l’instant je n’ai pas de solution à ce problème, la lecture est impossible car les données audio sont au début du fichier et les données vidéo a la fin, rendant impossible la lecture en streaming. Le fichier de Jipen a le meme problème j’imagine.

Jipen (Jipen)
mardi 14 mai, 2013 18:25:16

@Arnaud Vrac
Arnaud, le lien suivant http://dl.free.fr/mUhSJ4sqq donne un exemple de vidéo .MOV H264
qui ne passe pas avec la v1.2.7.
Peux-tu confirmer avec ce sample vidéo que le problème est identique, à savoir
la localisation des données audio en début de fichier et des données vidéo à la fin.
Merci.

adrenochrome (adrenochrome)
mardi 14 mai, 2013 21:00:37

en fait on peut faire le test assez simplement : en placant les fichiers sur un serveur web et en ouvrant ensuite les fichiers, dans vlc, en tant que “flux reseau” a partir de leur url en http
dans mon cas, toutes mes videos de test sont lues (mkv, avi, mp4, mov, ...) sauf celle du sujet

pour un protocole comme le http il ne doit pas y avoir trop de solution, mais pour les echanges entres le server et le player je suppose que vous devez avoir acces a des api plus elaborees.
En disant a vlc de s’appuyer sur un api proche du filesystem il devrait quand meme y avoir moyen d’attaquer la video avec deux pointeurs de fichier en // , non ?
d’ailleur, sur ordi, il arrive plutot bien a le faire en local sur la meme video(enfin sur la version integrale vu que dans les 20 premiers mo il n’y a que du son)

la video entiere est accessible ici
https://mega.co.nz/#!11Jz0BAQ!NKaZWkwr-oiR7y7-FDIoTHkO0cUPsL_oi5qb0G4tNJI

Arnaud Vrac (rawoul)
mardi 14 mai, 2013 21:10:37

Entre le serveur et le player c’est du http aussi. Ce n’est pas aussi simple que de telecharger l’audio et la video en parallele avec deux connexions ouvertes; effectivement ca fonctionnerait tres bien dans ce cas, et encore il peut aussi y avoir des sous-titres ailleurs.

Mais dans le cas générique les samples audio et video peuvent etre placés et entrelacés n’importe comment pour les formats MP4 et AVI. Idéalement les samples audio et vidéo pour un temps donnes sont proches, comme c’est le cas pour les MKV ou pour les fichiers AVI/MP4 bien muxés.

adrenochrome (adrenochrome)
mardi 14 mai, 2013 21:45:48

ou alors en autorisant la taille du buffer a s’etendre dynamiquement, jusqu’a avoir le quota minimal de trames audio et video...
a moins qu’il n’y ait pas de memoire virtuelle dans l’os :/

Arnaud Vrac (rawoul)
mercredi 15 mai, 2013 09:17:41

C’est le cas, le buffer a une taille max de 10MB, alors qu’il faudrait telecharger tout le fichier pour avoir des trames audio qui sont a la fin.

Chargement...