Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Close
  • Type de tâche Anomalie
  • Catégorie Services locaux → VM
  • Assignée à Personne
  • Système d'exploitation Tous
  • Sévérité Basse
  • Priorité Normale
  • Basée sur la version 4.5.2
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
  • Votes 0
  • Privée Non
Concerne le projet: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par bapgue (bapgue) - 26/10/2021
Dernière édition par Anisse Astier (aastier) - 18/11/2021

FS#35850 - VMs inaccessibles (écran + console) hors réseau interne depuis freeboxOs

les écrans et les consoles des VM sont inaccessibles depuis le lan externe, message : “XXX n’est plus joignable. Vérifiez que vous ne l’utilisez pas depuis une autre fenêtre, puis essayez de l’éteindre et le rallumer.”

ok depuis lan interne

Close par  Anisse Astier (aastier)
jeudi 18 novembre, 2021 14:34:17
Raison de clôture :  Résolu

Cette tache ne dépend pas d'autre tache

Anisse Astier (aastier)
jeudi 28 octobre, 2021 09:02:37

Bonjour,

Avez-vous bien vérifié que vous n’avez pas gardé un onglet ouvert sur la console de cette VM ? Il n’y normalement aucune autre contrainte liée au réseau interne/externe.

bapgue (bapgue)
vendredi 29 octobre, 2021 08:18:36

bonjour,

oui je suis sûr!
Est-ce que cela peut être lié avec une utilisation d’un réseau d’entreprise? Est-ce qu’il y a des appels à des services externes ou urls différentes ou des protocoles ou des ports spécifiques?

bapgue (bapgue)
vendredi 29 octobre, 2021 08:22:11

et je confirme, en 4G ça ne fonctionne pas mais si je me connecte au VPN de la BOX pour être “sur le réseau interne” ça fonctionne.

Anisse Astier (aastier)
mardi 9 novembre, 2021 14:27:45

Bonjour, aucun souci en 4G ici. Pourriez-vous préciser quel navigateur vous utilisez ? Quel est l’opérateur mobile en 4G; utilisez-vous une connexion sécurisée avec un domaine personnalisé pour Freebox OS?

bapgue (bapgue)
mardi 16 novembre, 2021 13:34:45

Bonjour, j’utilise chrome (dernière version) depuis un PC.
Je suis chez free mobile.
Je pense que vous avez raison : j’utilise un nom de domaine personnalisé en .hd.free.fr et j’accède en https à la box via un proxy inversé sur un port que je redirige via ce proxy.
Y-a-t-il des entêtes personnalisées à ajouter? activer le http/2 ?
Il n’y a que sur cette fonctionnalité que je rencontre des problèmes en utilisant ce même mode d’accès...

Anisse Astier (aastier)
mardi 16 novembre, 2021 13:38:36

Pour que la box autorise les connexions HTTP sur votre <domaine>.hd.free.fr, assurez-vous que ce dernier a bien été ajouté dans Freebox OS dans Paramètres → Mode avancé → Nom de domaine → Ajouter → “Je veux ajouter un nom de domaine que j’ai déja configuré”.

bapgue (bapgue)
mardi 16 novembre, 2021 15:26:57

oui, c’est bien le cas.

Anisse Astier (aastier)
mercredi 17 novembre, 2021 08:41:15

Les reverse proxy doivent être configurés correctement pour laisser passer les websockets, ce qui a certaines subtilités. L’upload de fichier pourrait aussi ne pas marcher par exemple.

Anisse Astier (aastier)
mercredi 17 novembre, 2021 08:47:17

Le conseil dans ce cas est d’utiliser la connexion sécurisée intégrée à Freebox OS, avec un <domaine>.freeboxos.fr; là ça devrait fonctionner.

bapgue (bapgue)
jeudi 18 novembre, 2021 14:17:49

bonjour, je comprends ce que vous dites, mais je n’arrive toujours pas à y accéder en direct depuis mon domaine perso en freeboxos.fr.

bapgue (bapgue)
jeudi 18 novembre, 2021 14:19:05

mais j’ai l’écran cette fois mais pas la console... etrange.

Anisse Astier (aastier)
jeudi 18 novembre, 2021 14:19:40

Si vous vous connectez sans reverse proxy via la connexion sécurisée freeboxos.fr, la console ne fonctionne pas ? Pensez à bien démarrer la VM avant d’ouvrir la console, et assurez-vous que la console n’est pas ouverte sur un autre navigateur ou onglet.

bapgue (bapgue)
jeudi 18 novembre, 2021 14:25:11

Sans Reverse proxy, en direct, j’ai bien l’écran d’une VM (et oui elle est allumée!!)
Par contre je viens de me rendre compte qu’il faut appuyer sur la touche entrée dans la console après avoir vu le message “<NOM_VM> est démarré”...
ça fonctionne donc, merci pour votre aide et votre réactivité, si Thibault pouvait être aussi cordial sur le sujet du DTS ça serait top!

Chargement...