Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie WAN → Fibre
  • Assignée à Personne
  • Système d'exploitation Freebox Server V7 (Delta)
  • Sévérité Critique
  • Priorité Normale
  • Basée sur la version 4.5.0
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
  • Votes 0
  • Privée Non

FS#35653 - Bridage : débit IPv4 divisé par 8 après 1 minute, le débit IPv6 reste OK

Bonjour

Depuis quelque temps (plus d’1 mois, peut-être même depuis avant l’été) je constate un comportement extrêmement surprenant et très gênant sur ma connexion fibre avec ma Delta.

Quand je reboot la box, j’ai un débit descendant de plus de 7gb/s en IPV4 et en IPV6, puis au bout d’1 minute, le débit IPV4 tombe à moins d’1gb/s alors que le débit IPv6 lui reste de l’ordre de 7gb/s à 8gb/s.

Pour récupérer le débit de 7gb/s à 8gb/s en IPv4, la seule solution est de reboot la box. Puis je récupère le débit IPV4 pendant 1 minute (le temps de faire un speedtest) puis il chute en dessous de 1gb/s très rapidement alors que (et j’insiste) le débit IPv6 lui reste de 7gb/s à 8gb/s.

PS: Je suis propriétaire des liens et des serveurs distants sur lesquels je fais les tests, le problème NE vient PAS de l’extérieur du réseau Free, c est soit une limite qui s’applique, soit un bug, mais en tout cas le problème ne vient pas des autres éléments. Le problème ne vient pas non plus du réseau fibre interne ou des équipements qui le composent.

Cordialement
nbanba

Cette tache ne dépend pas d'autre tache

loggoi (loggoi)
dimanche 26 septembre, 2021 08:54:47

Et en testant sur des serveurs distants/liens que vous ne gérez pas ?

nicolas nba (nbanba)
dimanche 26 septembre, 2021 09:35:44

Bonjour
C est pareil, quelque soit les liens ou les serveurs distants.
J ai testé vers tous les liens présent sur testdebit.info.
Résultat identique, quel que soit le peering ou l opérateur vers lequel je fais le test (scaleway/free, ovh, Bouygues, ...)
Cordialement
nbanba

nicolas nba (nbanba)
dimanche 26 septembre, 2021 09:39:13

Bonjour
J ai plutôt l impression que c est une limite qui s applique dynamiquement sur le routeur qui gère le trafic ipv4 après quelques dizaines de secondes ou après un certain nombre de paquets .
Cordialement
nbanba

webnet (webnet)
dimanche 26 septembre, 2021 12:38:40

IPV4 est tunnelisé dans l ipv6 par logiciel alors que l ipv6 est natif donc rien soft le routeur pour acheminer le protocole...........

Marios Makassikis (mmakassikis)
lundi 27 septembre, 2021 12:25:11

Bonjour,

Comment est fait le speedtest ? S’agit-il de trafic TCP ou UDP ? Pouvez-vous configurer une valeur de MTU plus faible sur l’équipement derrière la box et retester ?

Vous indiquez que le débit chute en dessous de 1Gbps. Quel est le débit mesuré concrètement ?

Est-ce vous pouvez laisser un ping tourner pour voir s’il y a de la perte de paquets ?

nicolas nba (nbanba)
lundi 27 septembre, 2021 13:09:01

Bonjour

Merci pour votre retour.
Petite précision : ce comportement est depuis quelques temps, je ne le constatait pas il y a 3 mois.

Les tests sont faits depuis des machines linux (1 serveur connecté à 16x10G SFP+) et mon laptop XPS15 connecté en thunderbolt à une carte SFP+ à 10g
Le serveur tourne sous Debian 11, mon laptop sous Debian 10

Le serveur et le laptop sont connectés sur un switch Cisco Nexus 9372PXE qui porte le “internal network” La Delta est connectée sur un UI ES16XG qui porte le “external network”
Un firewall Fortigate FGT101F est connecté en SFP+ d’un côté sur le UI ES16XG et de l’autre côté sur le Nexus 9372PXE, une policy mixte IPv4/IPv6 ALL ALL sans UTM est positionnée de l’“internal network” vers le “external network” pour le test.

Schéma :

@ <--8g--> FBX-DELTA <--10g--> UI ES16XG <--10g--> Firewall FGT101F <--10g--> NX9372PXE <--10g--> XPS15
                                                                                |
                                                                                |<------16x10g--> SERVER
                                                                                

Je viens de refaire des tests séquentiellement depuis les 2 machines SANS avoir reboot la box :

depuis le serveur :

Vers scaleway : ipv4 : débit 0,7g ipv6 : débit 3g


14:40:31 root@14RV-SERVER:~# wget -O /dev/null https://ipv4.scaleway.testdebit.info/10G.iso –2021-09-27 14:40:34– https://ipv4.scaleway.testdebit.info/10G.iso Résolution de ipv4.scaleway.testdebit.info (ipv4.scaleway.testdebit.info)… 62.210.156.7
Connexion à ipv4.scaleway.testdebit.info (ipv4.scaleway.testdebit.info)|62.210.156.7|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 75,7MB/s ds 2m 7s

2021-09-27 14:42:40 (75,4 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

14:42:40 root@14RV-SERVER:~#
14:49:07 root@14RV-SERVER:~# wget -O /dev/null https://ipv6.scaleway.testdebit.info/10G.iso –2021-09-27 14:49:15– https://ipv6.scaleway.testdebit.info/10G.iso Résolution de ipv6.scaleway.testdebit.info (ipv6.scaleway.testdebit.info)… 2001:bc8:3::7
Connexion à ipv6.scaleway.testdebit.info (ipv6.scaleway.testdebit.info)|2001:bc8:3::7|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 313MB/s ds 31s

2021-09-27 14:49:46 (304 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

Vers Bouygues : ipv4 : débit 0,7g ; ipv6 débit 7,9g


14:50:40 root@14RV-SERVER:~# wget -O /dev/null https://ipv4.bouygues.testdebit.info/10G.iso –2021-09-27 14:51:16– https://ipv4.bouygues.testdebit.info/10G.iso Résolution de ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)… 89.84.1.186
Connexion à ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)|89.84.1.186|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 75,3MB/s ds 2m 8s

2021-09-27 14:53:24 (74,3 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

14:53:24 root@14RV-SERVER:~# wget -O /dev/null https://ipv6.bouygues.testdebit.info/10G.iso –2021-09-27 14:53:43– https://ipv6.bouygues.testdebit.info/10G.iso Résolution de ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)… 2001:860:de01:1100::2
Connexion à ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)|2001:860:de01:1100::2|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 750MB/s ds 12s

2021-09-27 14:53:55 (795 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

depuis le XPS15 : résultats identiques :

Vers scaleway : ipv4 : débit 0,7g ipv6 : débit 3g


onnexion à ipv4.scaleway.testdebit.info (ipv4.scaleway.testdebit.info)|62.210.156.7|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 69,1MB/s ds 2m 13s

2021-09-27 14:32:51 (71,4 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

14:41:01 nba@lap-nba:~$ wget -O /dev/null https://ipv6.scaleway.testdebit.info/10G.iso –2021-09-27 14:49:53– https://ipv6.scaleway.testdebit.info/10G.iso Résolution de ipv6.scaleway.testdebit.info (ipv6.scaleway.testdebit.info)… 2001:bc8:3::7
Connexion à ipv6.scaleway.testdebit.info (ipv6.scaleway.testdebit.info)|2001:bc8:3::7|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 265MB/s ds 32s

2021-09-27 14:50:25 (297 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

Vers Bouygues : ipv4 : débit 0,7g ; ipv6 débit 6,5g


14:50:25 nba@lap-nba:~$ wget -O /dev/null https://ipv4.bouygues.testdebit.info/10G.iso –2021-09-27 14:54:17– https://ipv4.bouygues.testdebit.info/10G.iso Résolution de ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)… 89.84.1.186
Connexion à ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)|89.84.1.186|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 75,1MB/s ds 2m 10s

2021-09-27 14:56:27 (73,6 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

14:56:27 nba@lap-nba:~$ wget -O /dev/null https://ipv6.bouygues.testdebit.info/10G.iso –2021-09-27 15:00:05– https://ipv6.bouygues.testdebit.info/10G.iso Résolution de ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)… 2001:860:de01:1100::2
Connexion à ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)|2001:860:de01:1100::2|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 641MB/s ds 15s

2021-09-27 15:00:19 (646 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

Voici un MTR fait il y a quelques minutes :

mtr –report free.fr
Start: 2021-09-27T14:28:19+0200
HOST: lap-nba Loss% Snt Last Avg Best Wrst StDev

1.|-- _gateway                   0.0%    10    0.2   0.3   0.2   0.3   0.0
2.|-- freebox-server.local      10.0%    10    0.4   0.4   0.4   0.5   0.0
3.|-- 194.149.169.53            10.0%    10    2.5   2.5   2.3   2.9   0.2
4.|-- p11-9k-1-be1022.intf.rout 10.0%    10    2.7   2.4   2.0   2.7   0.3
5.|-- bzn-9k-2-sys-be2001.intf. 10.0%    10    3.2   3.0   2.7   3.5   0.3
6.|-- www.free.fr                0.0%    10    2.2   2.3   2.0   2.5   0.2

Là, je reboot la FREEBOX DELTA. il est 15h04

depuis le serveur :

Vers Bouygues : ipv4 : débit 0,7g ; ipv6 débit 6,5g


nicolas nba (nbanba)
lundi 27 septembre, 2021 13:17:14

Bonjour

@mmakassikis : sorry, j’ai appuyé surle bouton poster ...
Voici la suite du message ...

Là, je reboot la FREEBOX DELTA. il est 15h04

depuis le serveur :

Vers Bouygues : ipv4 : débit 7,9g ; ipv6 débit 6,9g

15:07:02 root@14RV-SERVER:~# wget -O /dev/null https://ipv4.bouygues.testdebit.info/10G.iso –2021-09-27 15:07:17– https://ipv4.bouygues.testdebit.info/10G.iso Résolution de ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)… 89.84.1.186
Connexion à ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)|89.84.1.186|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 784MB/s ds 12s

2021-09-27 15:07:29 (790 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

15:07:29 root@14RV-SERVER:~# wget -O /dev/null https://ipv6.bouygues.testdebit.info/10G.iso –2021-09-27 15:07:32– https://ipv6.bouygues.testdebit.info/10G.iso Résolution de ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)… 2001:860:de01:1100::2
Connexion à ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)|2001:860:de01:1100::2|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 703MB/s ds 14s

2021-09-27 15:07:46 (693 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

depuis le XPS15 : résultats identiques :

vers Bouygues : ipv4 débit 6,3g / ipv6 débit 6,7g

15:06:39 nba@lap-nba:~$ wget -O /dev/null https://ipv4.bouygues.testdebit.info/10G.iso –2021-09-27 15:07:49– https://ipv4.bouygues.testdebit.info/10G.iso Résolution de ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)… 89.84.1.186
Connexion à ipv4.bouygues.testdebit.info (ipv4.bouygues.testdebit.info)|89.84.1.186|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 626MB/s ds 15s

2021-09-27 15:08:04 (631 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

15:08:04 nba@lap-nba:~$ wget -O /dev/null https://ipv6.bouygues.testdebit.info/10G.iso –2021-09-27 15:08:08– https://ipv6.bouygues.testdebit.info/10G.iso Résolution de ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)… 2001:860:de01:1100::2
Connexion à ipv6.bouygues.testdebit.info (ipv6.bouygues.testdebit.info)|2001:860:de01:1100::2|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 10000000000 (9,3G) [application/x-iso9660-image]
Sauvegarde en : « /dev/null »

/dev/null 100%[=====================================⇒] 9,31G 632MB/s ds 14s

2021-09-27 15:08:22 (670 MB/s) — « /dev/null » sauvegardé [10000000000/10000000000]

Je ne refais pas le test vers les serveurs de scaleway qui sont plus chargés actuellement, mais ce serait identique, j’ai déjà tester 25 fois à différentes heures, et également vers les serveurs d’OVH.

D’ici quelques minutes (certaines fois 1 minute, d’autres fois 30 minutes) le débit IPv4 va chuter.

Je vais essayer de réduire le MTU , éventuellement d’ajutser le MSS, mais je reste surpris car je ne constatait pas ces soucis il y a quelques mois et je n’ai pas fais de changements d’infra depuis avant qu eje constate ce phénomène.

Merci pour votre aide,

Cordialement
nbanba

Neustradamus (Neustradamus_)
mardi 19 octobre, 2021 21:33:34

@nbanba: Du neuf en 4.5.1 ?

nicolas nba (nbanba)
mardi 19 octobre, 2021 23:25:12

Bonjour

@Neustradamus : merci pour l update... pour l instant je ne peux pas reboot la box, j ai un duplicate qui tourne, encore 7t a descendre ...
Je reboot demain et je vous dis.

Cordialement
nbanba

Chargement...