Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie Services locaux → SMB
  • Assignée à Personne
  • Système d'exploitation Freebox Server V6 (Révolution)
  • Sévérité Haute
  • Priorité Normale
  • Basée sur la version A PRECISER
  • Due pour la version Non décidé
  • Date d'échéance Non décidé

FS#34647 - [4.3] SMBv2 Problème d'accès au contenu des répertoires HDD sur Android & Chrome OS

Apres passage en SMB2, certains répertoires des disques connectés à la Freebox n’affiche plus leur contenu par l’intermédiaire d’Android ou Chrome OS. Cela fonctionne normalement en passant par Windows 10.

Cette tache ne dépend pas d'autre tache

Tehoden (Tehoden)
samedi 24 avril, 2021 19:06:18

Bonjour,
Je constate exactement le même souci. Je faisais partie des beta testeurs et j’ai échanger plusieurs mails avec Mr Makassikis à ce sujet. je vais essayer d’être le plus clair possible. J’ai un disque de 5 To, en NTFS, connecté sur le serveur pop (sur l’Usb3 et le disque est USB3 aussi). Le disque est neuf, acheté en Janvier dernier, un peu avant le début de la béta. J’ai constaté que, sur certains répertoires (ceux avec beaucoup de fichier), si je fais un clic droit sur un fichier, la fenêtre des propriétés affiche un poids de 0Ko et aucune date de création/modification:
nsm09.casimages.comimg2021042421042408501917398417385462.jpg

Dans ce même répertoire, certains affichent correctement la fenêtre des propriétés et certains, comme l’image ci-dessus, sans rien.
Si on tente de parcourir le répertoire en question, par la commande dir en fenêtre CMD, le comportement est également très bizarre. une fois dans le répertoire, si je fais simplement dir, tous les fichiers du répertoire sont trouvés mais pas par ordre alphabétique. Ils sont bizarrement classés. Ils ont l’air (c’est à dire la majorité d’entre eux) d’être par ordre alphabétique mais pas du tout. Tous ceux qui sont pas bien “classés” sont ceux qui présente le bug de la fenêtre de propriétés. j’ai tenté toutes les options de la commande dir mais ça reste pas dans le bon ordre.
De plus, si, sur un fichier présentant le bug de la fenêtre des propriétés, je tente de faire un dir débutdunomdufichier*.*, là, la commande dir me répond que le fichier est inexistant. Résultat étonnant car un dir simple l’a pourtant bien “trouvé”, il est listé. Alors certes, pas au bon endroit dans l’ordre alphabétique mais il est là.

Bug lié à tout ça : Si dans VLC par exemple (depuis téléphone Android ou le lecteur freebox pop), je tente l’accès sur le répertoire avec ce bug, VLC me répond que, tenez vous bien, le répertoire est vide! alors qu’il contient plus de 200 fichiers.

Je vérifie le disque, histoire qu’il ne soit pas défectueux. Je branche le disque sur mon pc puis je le partage sur mon réseau (mon pc a bien smb V1 de désactivé bien sûr et tous les VLC utilisés ont l’option “préférer smbv1” de décochée également). Et la, tout fonctionne parfaitement, tous les répertoires sont biens listés par VLC, du téléphone, de la freebox tout ... impec. Le bug de la fenêtre des propriétés à 0 disparait. Les commandes dir fonctionnent parfaitement. Le disque n’est donc pas en cause.

Une fois le disque rebranché sur la freebox, le bug est de retour. Je constate que n’importe quel répertoire dépassant les 30 fichiers présente ces bugs (mais ce n’est peut être pas pile ce nombre à partir duquel le bug se présente mais j’ai pas mieux, j’ai soit des répertoires à moins de 30 fichiers et la aucun souci ou j’ai beaucoup plus de 30, genre 80-100 voir plus de 200 fichiers, où la le bug est présent) :

- Des fichiers avec fenêtre de propriétés à 0
- exploitation par dir en fenêtre de commande CMD bugée
- VLC ne trouve rien dans ces répertoires, il les voit vide

J’ai refais plusieurs mails à Mr Makassikis mais sans réponses cette fois. J’ai pu voir qu’on était plusieurs à rencontrer des bugs assez similaires (avec d’autre logiciels que VLC). Je pense qu’il reste un bug, lié au nombre de fichiers contenus (ou bien tout autre chose mais il reste un bug, assez gênant car perturbe l’utilisation de VLC).

En espérant avoir une réponse cette fois, sinon je ferais un ticket peut être indépendant histoire de remonter le souci.

Merci beaucoup @ bientôt. Tehoden.

Anisse Astier (aastier)
vendredi 30 avril, 2021 14:03:49

Bonjour @Tehoden, évitez de mélanger les rapports de bugs SVP.

@Bertrand : avec quelle application Android accédez vous au partage ?

Bertrand Tumoine (BT2)
vendredi 30 avril, 2021 17:16:46

Bonjour,
J ai essaye avec VLC et X-Plore, aucun des 2 ne fonctionnent.

Chargement...