Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Close
  • Type de tâche Anomalie
  • Catégorie LAN → NAT (redirections, DMZ)
  • Assignée à Personne
  • Système d'exploitation Tous
  • Sévérité Critique
  • Priorité Normale
  • Basée sur la version A PRECISER
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par Yann B. (spideryan) - 22/04/2021
Dernière édition par Maxime Bizon (mbizon) - 06/05/2021

FS#34622 - PB Softphone Pro depuis 4.3.0

Bonjour,

Nous constatons que plusieurs de nos utilisateurs télétravaillant, ne peuvent plus utiliser le softphone pro derrière la Freebox (Révolution, Pop, Delta)

Tout fonctionnais correctement en 4.2.10, je suis moi-même encore dans cette version et je n’ai aucun souci actuellement.

Par contre j’ai 2 utilisateurs qui sont passé en 4.3.0 et 4.3.1 et là c’est la catastrophe ils ne peuvent plus utiliser le softphone

Avez-vous réintégré du sip ALG à votre box et pouvez vous corriger cela rapidement

Merci par avance
Yann

Close par  Maxime Bizon (mbizon)
jeudi 6 mai, 2021 07:16:23
Raison de clôture :  Résolu

Cette tache ne dépend pas d'autre tache

Maxime Bizon (mbizon)
jeudi 22 avril, 2021 08:22:55

Effectivement nous avons intégré (pas re-intégré) un ALG SIP, pouvez vous me dire quel modèle de softphone vous utilisez ?

Maxime Bizon (mbizon)
jeudi 22 avril, 2021 08:34:18

Pouvez vous me donnez également le type connexion de vos collaborateurs, ainsi que les paramêtres SIP:

- connexion fibre ou dsl
- IPv4 avec ports partagés, ou IPv4 “complète” (sans demander), ou IPv4 full stack (tous les ports, mais suite à demande explicite sur la console abonnée).
- idéalement leurs adresses MACs
- et pour le SIP, UDP ou TCP/SSL ? et la sig SIP est-elle en IPv4 ou IPv6 ?

Merci

Yann B. (spideryan)
jeudi 22 avril, 2021 09:28:24

Bonjour Maxime,

Merci pour ce retour rapide, voici les réponses :

Nous utilisons un softphone propriétaire de notre fournisseur ENREACH (ex CENTILE)
Nous utilisons le SIP 5060 UDP et IPV4 exclusivement

Premier utilisateur 4.3.1 :
- XDSL
- IPv4 full stack (demandé hier)
- 34:27:92:47:0E:77

Second utilisateur 4.3.0 :
- FTTH
- IPv4 full stack
- 8C:97:EA:33:18:72

pour ma part, mais je n’ai pas encore redémarré donc encore en 4.2.10 :
- FTTH
- IPv4 full stack
- 8C:97:EA:33:18:72

Comment pouvons-nous contourner ce problème très rapidement, car cela impacte directement la production de mes utilisateurs ?

Si utile je veux bien redémarrer ma box, mais faut avoir une solution de replis rapide

Merci d’avance

Maxime Bizon (mbizon)
jeudi 22 avril, 2021 09:36:19

Je n’ai pas de solution de contournement immédiate, je regarde si c’est plus rapide de corriger l’ALG SIP ou de faire une option pour le désactiver.

Pouvez vous me décrire exactement le problème, est ce que c’est l’audio qui ne marche pas (flux RTP), ou même la partie SIP (register, ...) pose probleme ?

Yann B. (spideryan)
jeudi 22 avril, 2021 09:55:58

Ok

D’expérience et j’ai pu le constater sur divers équipements, le mieux est de permettre la désactivation (c’est ce que SFR a fait sur sa dernière box)

Le problème est très aléatoire, car il impacte par moment le register et le plus souvent la signalisation ce qui empêche de lancer l’appel ou de le décrocher, donc le flux RTP n’est pas utilisé, car l’appel ne peux être établi

Maxime Bizon (mbizon)
jeudi 22 avril, 2021 10:01:09

Vous voulez dire que ça marche parfois ? (si le problème est aléatoire)

Yann B. (spideryan)
jeudi 22 avril, 2021 10:41:39

Ok

D’expérience et j’ai pu le constater sur divers équipements, le mieux est de permettre la désactivation (c’est ce que SFR a fait sur sa dernière box)

Le problème est très aléatoire, car il impacte par moment le register et le plus souvent la signalisation ce qui empêche de lancer l’appel ou de le décrocher, donc le flux RTP n’est pas utilisé, car l’appel ne peux être établi

Yann B. (spideryan)
jeudi 22 avril, 2021 10:43:10

Non cela ne fonctionne jamais depuis la mise a jour, mais le dysfonctionnement provient par moment du register et le plus souvent la signalisation ce qui empêche de lancer l’appel ou de le décrocher

Julien OHAYON (Appliwave)
jeudi 22 avril, 2021 15:39:58

Je confirme nous avons aussi ce problème depuis la MAJ sur notre plateforme Enreach.
Les paquets SIP sont modifiés et donc nous avons des problèmes aléatoires d’invite etc...

Il faut absolument trouver une solutions, beaucoup d’utilisateurs en télétravail ne peuvent plus utiliser leurs services de téléphonies pros.

Julien OHAYON (Appliwave)
jeudi 22 avril, 2021 15:41:15

Pas précisé, c’est du SIP sur le port 5060 en UDP ou TCP non chiffré

nicolas nba (nbanba)
vendredi 23 avril, 2021 10:45:50

Bonjour

Avec un téléphone Mitel 6867i sur IPBX MiVOICE 5000 j’ai des soucis depuis la MAJ en 4.3.0

archi :

IPBX ←–> Firewall étendant le LAN VOICE (VxLAN encap UDP 4789) ←—> CELESTE PROVIDER ←–@@@@—> Freebox Delta ←—> Firewall portant le VxLAN VOICE ←—–> téléphone Mitel 6867i

Pour info, SIP ALG est désactivé sur les firewalls des 2 côtés.

Ce design fonctionnait très bien depuis le début de la période COVID (des mois...) et s’est arrêté de fonctionné à la MAJ en 4.3.0

Les autres téléphone Mitel 6867i chez d’autres personnes utilisant d’autres providers internet continuent de fonctionner normalement (4 téléphones: 2 sur ligne Bouygues, 1 sur ligne SFR , 1 sur ligne Orange)

Depuis la mise à jour en 4.3.0 le téléphone ne se synchronise plus sur l’IPBX.

Un coup de tcpdump de chaque côté montre la conséquence de cette non synchro initial :

diag sniffer packet port9 none 4
interfaces=[port9]
filters=[none]
pcap_lookupnet: port9: no IPv4 address assigned
13.885021 port9 – lldp 246 chassis 5 port 3 00:08:5d:57:6a:a8 ttl 120 system ‘Mitel IP Phone’ 44.916746 port9 – lldp 246 chassis 5 port 3 00:08:5d:57:6a:a8 ttl 120 system ‘Mitel IP Phone’ 51.097600 port9 – 802.1Q vlan#100 P5
52.096982 port9 – 802.1Q vlan#100 P5
53.096989 port9 – 802.1Q vlan#100 P5
55.210060 port9 – 802.1Q vlan#100 P5
...

Le téléphone fallback automatiquement sur le vlan transmis par LLDP qui est désactivé dans la conf du téléphone (normal ici) car le VxLAN étend le LAN VOIP et non le VLAN VOIP de l’entreprise.
Des trames 802.1q sont donc transmises par le téléphone sur le VXLAN ce qui ne devrait pas, le téléphone devient donc “aveugle” de l’IPBX

Ce comportement ressemble à un effet de bord d’un autre souci survenu depuis le passage en 4.3.0, la solution était en production depuis plusieurs mois et s’est arrêté de fonctionné quelques minutes après la MAJ en 4.3.0

Ce problème impactant le télétravail (obligatoire avec le COVID) et les particuliers ne pouvant pas avoir des accès internet PRO à domicile, merci de regarder / corriger le souci rapidement.

Cordialement
nbanba


gerald (ggvanxl)
mercredi 28 avril, 2021 15:57:43

Je confirme ce problème avec téléphone IP et Softphone SIP en TCP. 2 remontées de deux personnes différentes sur freebox cette semaine alors que cela fonctionnait précédemment.
Info tehcnique telephonie:
REGISTER toutes les 2mn mais la box reset la connexion TCP ensuite, aucune réception de REGISTER côté serveur.
Sans doute une clôture un peu brutale de la socket TCP SIP après 1mn.

En tout ca pouvoir désactiver l’ALG SIP serait bienvenu. Cette demande est assez urgente avec le télétravail en place...

nicolas nba (nbanba)
jeudi 29 avril, 2021 05:38:20

Bonjour

@FREE DEVELOPPERS :

Cela fait maintenant 1 semaine que le problème persiste.

En basculant la route internet par défaut sur une autre connexion, le téléphone se synchronise directement
La bascule de la route internet est le fruit d’un lourd bricolage avec un deuxième firewall faisant routeur + wifi et un téléphone Bouygues en 4G partageant sa connexion + surtout 2 jours de travail hautement technique pour étendre le L2 VOIP au travers d’une topologie réseau ne fournissant pas d’IP publique sur laquelle on peut ouvrir des ports...

Vous vous en doutez certainement, j’ai besoin de mon téléphone mobile pro pour autre chose que pour faire fonctionner mon téléphone fixe pro qui ne fonctionne plus derrière la Freebox !

À défaut d’un correctif, il nous faudrait au moins une date prévisionnelle de sortie d’un patch à communiquer à nos entreprises.

En vous remerciant d’avance,
Cordialement
nbanba

Emmanuel DECAEN (decaen)
jeudi 29 avril, 2021 08:07:43

Bonjour,

Depuis la mise à jour 4.3, il y a également un problème SIP avec de la borne DECT Gigaset N720 (connectée à un Asterisk).
Le son ne passe que dans un sens : un seul correspondant entend l’autre

En regardant avec une capture tcpdump, on voit que l’échange SIP a bien lieu, mais côté RTP, ça couine une peu:
Le flux RTP émis par la borne arrive bien à l’Asterisk, mais malheureusement le flux retour n’arrive pas à la borne (Asterisk envoie le RTP vers l’adresse IP privée).

Connexion Freebox :
- connexion fibre
- IPv4 full stack
- adresse MAC : 00:24:D4:78:09:B4
- SIP: 5060 UDP
- Sig SIP en IPv4

Il est à noter que la borne DECT Gigaset N870 derrière la même freebox continue à fonctionner sans problème particulier.
En entendant la résolution, j’ai basculé tous les téléphones (sauf un) sur la Gigaset N870.

Je peux faire des tests si besoin.

Merci

nicolas nba (nbanba)
jeudi 29 avril, 2021 10:43:12

Bonjour

Je peux également faire des tests avec une infra VOIP complète si besoin.

Mais dans tous les cas, merci de nous fournir une date à transmettre à nos employeurs.

Cordialement
nbanba

gerald (ggvanxl)
jeudi 29 avril, 2021 13:28:41

Une partie du pb peut être contourné pour SIP sur TCP.
En mettant côté poste (qd c’est possible) du TCP Keep-Alive, la socket reste ouverte et le service fonctionne (confirmé).

Cela ne règle pas les pb rencontrés sur UDP.

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 13:36:14

Bonjour,

Une personne m’a gentillement mis à disposition un accès à une plateforme Centille (avec l’appli “softphone”), et j’ai corrigé le problème pour cette plateforme.

Je peux mettre un firmware beta à disposition aux personnes qui veulent confirmer que c’est bien ok.

Pour les personnes ayant des autres problèmes:
- Gigaset N720
- IPBX MiVOICE 5000

⇒ je peux également vous mettre en bêta pour voir si c’est corrigé, sinon on peut débugger ensemble

Emmanuel DECAEN (decaen)
jeudi 29 avril, 2021 14:03:57

Bonjour,

Ok pour passer en bêta pour tester avec le Gigaset N720.

Merci.

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 14:47:58

@decaen

C’est ok

Peu de chance que ça marche du premier coup sans avoir testé avant, l’étape d’après sera de faire des captures réseaux (je peux les faire de mon coté)

gerald (ggvanxl)
jeudi 29 avril, 2021 14:49:02

Une partie du pb peut être contourné pour SIP sur TCP.
En mettant côté poste (qd c’est possible) du TCP Keep-Alive, la socket reste ouverte et le service fonctionne (confirmé).

Cela ne règle pas les pb rencontrés sur UDP.

Emmanuel DECAEN (decaen)
jeudi 29 avril, 2021 14:54:28

@Maxime

Dois-je redémarrer la freebox maintenant pour la maj en beta ?

Il faudra faire attention, il y a deux bornes DECT Gigaset derrière la Freebox, une N870 (qui fonctionne bien) et la N720 (qui ne fonctionne plus).
Je peux fournir les éléments par message privé ou mail.

Ok pour la capture de votre côté.

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 14:57:35

@decaen

oui il faut redémarrer pour appliquer la mise à jour

et oui vous pouvez me contacter par email ça sera plus pratique

Emmanuel DECAEN (decaen)
jeudi 29 avril, 2021 15:05:42

C’est fait.
Voici mon adresse mail: ed <at> xsalto.com

nicolas nba (nbanba)
jeudi 29 avril, 2021 15:06:27

Bonjour

@mbizon :
Merci pour votre retour, je veux bien également tester si ça corrige le souci sur MiVOICE.

modèle : Freebox v7 (r1)
serial : 957602J184902073
hw addr: 34:27:92:63:39:90

Cordialement
nbanba

Emmanuel DECAEN (decaen)
jeudi 29 avril, 2021 15:08:40

Le 4.3.2-pre1 n’a pas corrigé le problème sur la borne Gigaset N720.

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 15:09:46

@nbanba

voila

idem si ça ne corrige pas on va faire des traces

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 15:09:59

@decaen: je vous ai fait un mail

nicolas nba (nbanba)
jeudi 29 avril, 2021 16:20:15

Bonjour

@mbizon

Merci beaucoup, reboot imminent.

Cordialement
nbanba

nicolas nba (nbanba)
jeudi 29 avril, 2021 16:39:09

Bonjour

@mbizon

Après reboot, le firmware est toujours flag 4.3.0 et non 4.3.2-pre1 .
Est ce normal ?

Le reboot a été très rapide, et je pense unique.
Je n’ai pas l’impression que le firmware ait été flashé, ce qui aurait probablement provoqué un second reboot, non ?

Cordialement
nbanba

Maxime Bizon (mbizon)
jeudi 29 avril, 2021 16:51:41

@nbanba: oops j’avais mal rentré votre adresse MAC

devrait etre mieux maintenant

Yann B. (spideryan)
jeudi 29 avril, 2021 19:19:13

@mbizon

Je suis intéressé de tester là version bêta svp

Mac : 8C:97:EA:33:18:72

Je vous laisse me contacter en privé si besoin d’info

Cdt,
Yann B.

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 07:01:07

@Yann B Voila

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 07:06:00

Pour information, Si le firmware bêta ne règle pas votre problème (comme c'est le cas pour @decaen), j'ai un deuxième essai à faire en activant manuellement une fonction sur votre Freebox. Cette option est désactivée par défaut et volatile (se désactive au reboot), donc il ne faudra plus redémarrer la freebox pour faire le test. Cette option a corrigé le problème de @decaen et sera activée automatiquement dans le prochain firmware bêta.

Pierre-Olivier CESARI (e-neolab)
vendredi 30 avril, 2021 09:52:22

Bonjour Maxime prévoyez-vous une case a décocher "disable SIP ALG" ? ça serait plus que bien. cordialement

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 10:18:33

@e-neolab Malheureusement le SIP peut être utilisé par la freebox pour ses propres besoins de téléphonie, la désactivation entraînerait donc un service téléphonie non fonctionnel. D'où ma priorité de corriger l'ALG si possible, et de ne garder cette solution de cette case à cocher qu'en dernier recours.

Pierre-Olivier CESARI (e-neolab)
vendredi 30 avril, 2021 10:22:16

@mbizon je comprends. A ce moment là est-ce que le sip alg ne pourrait être activé que sur udp/5060 et laisser le tcp/5060 "un peu plus entreprise" sans SIP ALG ?

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 11:18:37

@e-neolab C'est une idée oui. Je sors ce firmware urgemment avec au moins les correctifs, et je regarde pour la solution long terme.

Guibert Jérémy (jguibert)
vendredi 30 avril, 2021 11:39:38

Bonjour. Désolé si ma réponse n'a pas sa place ici mais je pense que je suis concerné par le problème. Nous utilisons la solution MyIstra de Centile depuis 1 an maintenant. Depuis peu, nous avons régulièrement des plaintes de nos collègues pour nous dire que le softphone ne fonctionne pas. Après investigation de ma part, il apparait que lorsque l'agrégation 4g est activée, nous n'avons de son (le correspondant ne nous entend pas et nous n'entendons rien non plus). Lorsque je désactive l'agrégat, je relance MyIstra, je lance (ou reçois) un appel et tout fonctionne correctement. Test sur FB Delta. Cordialement, Jérémy Guibert

Guibert Jérémy (jguibert)
vendredi 30 avril, 2021 11:44:04

* XDSL * Freebox Delta en 4.3.0 * 70:FC:8F:51:FA:0A * IPv4 FULL STACK (demande via console abonné)

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 11:51:15

@jguibert ok pour la beta

Guibert Jérémy (jguibert)
vendredi 30 avril, 2021 12:22:57

Merci, je viens de testé : toujours pas de retour son mais on m'entend maintenant ! (peut être que c'était le cas avant) Si je désactive la 4g, c'est pleinement fonctionnel :(

Maxime Bizon (mbizon)
vendredi 30 avril, 2021 12:42:24

@jguibert: pouvez vous retester maitenant ? (j'ai changé le fameux paramètre volatile que je décrivais au dessus, ne rebootez pas pour faire le test)

Guibert Jérémy (jguibert)
vendredi 30 avril, 2021 12:56:59

Merci pour ces retours rapides. Alors : 4G Activé : Si je reçois l'appel c'est bon. Si j'émets un appel depuis mon softphone par contre le problème est identique (pas de retour son mais on m'entend) 4G désactivé : tout est OK

Yann B. (spideryan)
vendredi 30 avril, 2021 13:13:24

@mbizon je viens de redémarrer et je n'ai pas la version bêta merci de me contacter en urgence svp [[ybaudinat@icloud.com]]

nicolas nba (nbanba)
vendredi 30 avril, 2021 14:09:39

Bonjour @mbizon : Désolé, je suis en clientèle aujourd'hui, pas de possibilité de debug en live. Sur Mitel MiVOX 5000, j ai des améliorations (plus de fallback sur le VLAN poussé par lldp) mais j ai encore des soucis de synchro avec l IPBX. Je serais dispo lundi pour troubleshoot. Merci encore Cordialement nbanba

Granier (WIlliam30)
lundi 3 mai, 2021 12:31:25

Bonjour, J'ai une solution Centrex, je retrouve le même problème après avoir réalisé plusieurs trace Wireshark je confirme la présence de SIP ALG actif depuis la mise à jour 4.3, je peux recevoir mais pas émettre des appels. Quelle solution pourriez vous apporter au problème. Dans l'attente de votre retour. Cordialement.

Maxime Bizon (mbizon)
lundi 3 mai, 2021 16:43:51

Le firmware 4.3.2 définitif est disponible pour les gens en bêta-test. Dans Freebox OS => Paramètres => Connexion, vous pouvez changer la configuration de l'ALG SIP, ou le désactiver. Le firmware sort demain matin sauf problème.

Granier (WIlliam30)
lundi 3 mai, 2021 19:13:03

Merci pour votre retour, comme faire partie des bêta-test ? Cordialement.

Emmanuel DECAEN (decaen)
lundi 3 mai, 2021 21:01:25

Bonsoir, Merci pour le nouveau firmware. Je viens de faire le reboot en version 4.3.2, j'ai bien les trois choix dans la case SIP ALG. Je fais le test avec les bornes Gigaset demain matin. Merci.

Granier (WIlliam30)
lundi 3 mai, 2021 21:24:11

Voici mon Adresse Mac DC:00:B0:3A:15:80

Maxime Bizon (mbizon)
mardi 4 mai, 2021 06:47:45

@William30 plus nécessaire de faire du bêta test car avec la possibilité de désactiver l'ALG SIP le comportement sera identique à la version 4.2.x @decaen en théorie pour vous il faut le mode "tout média", ou le mode désactivé vu que ça fonctionnait avant.

Emmanuel DECAEN (decaen)
mardi 4 mai, 2021 06:54:29

Effectivement, les options "Activé (tout média)" et "Désactivé" fonctionnent avec le Gigaset N720. Merci.

Maxime Bizon (mbizon)
mardi 4 mai, 2021 06:56:33

@tous voila la version 4.3.2 est en production

nicolas nba (nbanba)
mardi 4 mai, 2021 13:52:43

Bonjour Merci pour le correctif, en mode "désactivé" les téléphones MITEL 6XXXi sur IPBX MiVOICE 5000 refonctionnent normalement. Je n'ai pas encore testé le mode "tout média", je vous dirais quand j'aurai fais le test. Merci encore, Cordialement nbanba

ludo453 (ludo453)
mardi 4 mai, 2021 15:47:01

Bonjour, Je ne vois pas ou désactivé le SIP ALG

Chargement...