Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • État Close
  • Type de tâche Anomalie
  • Catégorie WAN → Agrégation 4G
  • Assignée à Maxime Bizon (mbizon)
  • Système d'exploitation Freebox Server V7 (Delta)
  • Sévérité Critique
  • Priorité Normale
  • Basée sur la version 4.0.4
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par Jack G (Gjack974) - 22/04/2019
Dernière édition par Maxime Bizon (mbizon) - 26/04/2019

FS#26967 - Reboot intempestif du server V7

hier soir vers 21h ,le server delta commencé à faire redémarrage “complet” toute les 2 ou 3 minutes. ( redémarrage “complet” : extinction du serv - logo free - etape 1 .....)

Apres plusieurs tests, j’ai pu voir que le problème venait de l’agrégation 4G.
En désactivant la 4G le server fonctionne normalement, plus de reboot .
Je pense que le module est HS, il a fonctionné parfaitement jusqu’à maintenant.

version : Freebox V7 (r1) 4.0.5
Numéro de serie module xDSL + 4G : 957700A184610028

Close par  Maxime Bizon (mbizon)
Friday 26 April, 2019 13:59:14
Raison de clôture :  Résolu

Cette tache ne dépend pas d'autre tache

Philippe VILMINT (DarwinZ69)
Monday 22 April, 2019 08:18:19

Le problème est présent depuis le FW 4.0.5 lorsque le besoin en bande passante fait appel à la 4G ça fait planter la connexion.Si on désactive la 4G ça fonctionne c'est un contournement mais bon personnellement la Delta c'était aussi pour l'agrégation :-/

Jack G (Gjack974)
Monday 22 April, 2019 08:26:25

J'ai eu le service technique ce matin, le problème ce produit dès que la module 4g récupère le signal. Une expertise est en cours pour déterminer si c'est un problème matériel ou logiciel .
Pour l'instant j'ai désactivé l'agrégation 4g. À suivre...

Philippe VILMINT (DarwinZ69)
Monday 22 April, 2019 08:28:46

Merci pour l'info ;-)

macpoupou (macpoupou)
Monday 22 April, 2019 11:04:09

Même problème ici.

Ultraboss (Ultraboss)
Monday 22 April, 2019 13:47:20

Bonjour, idem chez moi également :-(

macpoupou (macpoupou)
Tuesday 23 April, 2019 04:47:29

A confirmer. Mais après ré activation... plus de reboot. Et plus d’agrégation.... peut être un passage en ipv6 résoud le pb. A tester.

Nicolas (NicolasToulouse)
Tuesday 23 April, 2019 09:26:31

Idem à coté de Toulouse (donc général sur le territoire a priori), depuis la MAJ 4.0.5, des déconnexions intempestives toutes les 3 / 4 minutes, il m'a fallu un moment pour comprendre que ça ne venait pas d'un bug du réseau ou de la tempête de vent dehors.

Désactivation de l'agrégation 4G sur la Delta et hop! Magie, plus aucune déconnexion! Par contre des qu'on remet l'agrégation en marche, ça replante comme avant!

Philippe VILMINT (DarwinZ69)
Tuesday 23 April, 2019 09:51:43

@Macpoupou suis en IPV6 et même problème.

Moi j'ai vraiment constaté que c'est lorsque j'avais des besoins en bande passante avec l'agrégation ADSL+4G activée que ça faisait rebooter la box.
Je pensais à un pb de protocole VPN avec l'IPV6 au départ mais non c'est bien lorsque que je tape dans la bande passante que ça plante.

Je peux rester plusieurs heures sans reboot en utilisation classique d'Internet par contre si je lance un téléchargement important (torrent) ça se passe bien au début et puis lorsque le débit augmente et passe le cap de mon débit ADSL max ça chute violemment et ma box reboot.
C'est bien la loose !

Nicolas (NicolasToulouse)
Tuesday 23 April, 2019 10:18:57

Oui Philippe, c'était exactement la meme situation chez moi!
Par contre j'ai trouvé sur le Forum une astuce qui chez moi fonctionne parfaitement, je fait le test depuis à peu prés une heure et ca ne bugue plus, malgré l'agrégation 4G..
En espérant que cela "tienne" et que ça marche aussi chez vous!!

https://dev.freebox.fr/bugs/task/26891

julnath (julnath)
Tuesday 23 April, 2019 10:19:27

Bonjour, même problème pour moi. ainsi que des soucis de connections ipsec aléatoire quand l'agregation est activé. (Enfin pendant les 4 min...)

cedric (frcydrex)
Tuesday 23 April, 2019 14:24:38

bonjour,
j'ai a peu près le même problème: ma freebox reboot avec l'agrégation mais que si j'utilise un logiciel pour télécharger un torrent (comme philippe), mais pas si je fais un speedtest (qui utilise aussi toute la bande passante + la 4G)
et cela depuis la mise a jour

Philippe VILMINT (DarwinZ69)
Tuesday 23 April, 2019 15:01:33

@Nicolas (NicolasToulouse) j'avais vu ton astuce (Merci au passage) et j'avais tenté mais ca n'a rien changé chez moi :-(.Je ne l'avais pas activé car comme mentionné par Free, certains téléphones notamment Android ne marche pas en IPV6 du coup impossible de se connecter avec eux au WIFI en DHCP si l'option est activée.J'ai laissé l'option en mettant sur mon téléphone de boulot une ip fixe sur le WIFI.

Franck Gaillard (Frankygailla)
Tuesday 23 April, 2019 16:47:42

Même probléme... J'ai fait la MAJ 4.0.5 aujourd'hui et depuis des que l’agrégation 4G s'enclenche ça fait planter la delta (presque 1 plantages par minutes....), du coup j'ai été forcer de désactiver l’agrégation alors que j'en était très satisfait sur la version 4.0.4 qui marchais parfaitement.... :/

J'ai bien le DHCPV6 d'activer.

J’espère vraiment une résolution rapide ou un roll back sur la précédentes version parce que la c'est du n'importe quoi la MAJ qui plante tout...

alexandre (khenty)
Tuesday 23 April, 2019 17:49:45

Bonsoir,

Cette anomalie fait penser à un reboot de la Freebox Server suite à une surchauffe.
N'auriez vous pas constater une augmentation des températures dans Freebox OS ?

Nicolas (NicolasToulouse)
Tuesday 23 April, 2019 20:24:22

Pas de mon coté, j'avais pensé à une micro-coupure electrique à cause de la tempete de vent, mais verification et branchement sur un onduleur on-line qui régule les prob de tensions, rien n'avait changé. Par contre des qu'on désactive l'agregation 4G, c'est un miracle, tout tourne nickel! et des qu'on remet l'agregation..boom! plantage au bout de qq minutes maxi! Surtout lors d'un telechargement Torrent ou là ca marche moins d'une minute a peine!
La Freebox reboote toute seule..sans arret..en gros nous avons une super Freebox Delta ADSL/4G...sans la 4G!
Autant garder une Révolution à 29,99€!

Nicolas (NicolasToulouse)
Tuesday 23 April, 2019 20:33:56

Bon dernier essai, pas de plantage de la box lors de l’agrégation 4G activée, lors d'un surf classique, ni d'un test débit sur degrouptest (VPN activé et désactivé), par contre, des qu'U TORRENT télécharge, au bout de qq secondes, BOOM! plus de connexion et Reboot de la Box lorsque l'Agrégation 4G est active et tout marche lorsque l'agrégation est désactivé.
Retour à la case départ donc, que ce soit avec ou sans DHCP V6.. AAHHHHHHH!!!!!!GRRRRRR!!!

Drakko (Drakko)
Tuesday 23 April, 2019 20:39:34

Bonsoir,

Le même constat pour moi. Mon serveur reboot dès que le début dépasse un peu la valeur de l’ADSL.

De même je ne vois plus du tout de valeurs dans l’agrégation 4G. Ça n’affiche même pas 0. Rien.

Free a donc bien totalement raté son coup en voulant juste ajouter une alerte en cas d’atteinte du volume autorisé...

macpoupou (macpoupou)
Wednesday 24 April, 2019 19:53:36

Bon en fait, la box reboot dès que l'agrégation 4G s'active... Je n'ai pas encore essayé l'option DHCP v6.

Nicolas (NicolasToulouse)
Thursday 25 April, 2019 09:32:31

Si quelqu'un à des news de FREE (annonce, communiqué, ou réponse du service technique) concernant ces énormes bugs de 4G et de VPN avec la derniere M.A.J, qu'il nous le fasse savoir :)

alexandre (khenty)
Thursday 25 April, 2019 12:12:25

Bonjour,

Défaut connu,
En cours d'analyse.

Résolution : Pas d'info pour le moment sur une date :)

Rioux yann (furnet)
Thursday 25 April, 2019 16:39:31

bonjour,

Même combat ici. Dès que je sollicite la 4G, BOOOM, le serveur reboot, tout se fige. on repasse les étage "Free, étape 1, etc".
A la moindre nécessité de télécharger un fichier, dès que l'ADSL atteint son max (pour moi 4Mb), la 4G prend le relais et tout s'arrête nette.
A ce jour, obligation de décocher la case 4G pour me permettre de télécharger des fichiers (Pro depuis un VPN ou perso depuis un fichier Torrent ou DDL)
Bref, je commence à me dire que c'était mieux avant... Mais je garde la Foix!! LooL

LARDENNOIS (Squirrel71)
Thursday 25 April, 2019 18:28:13

Même pb pour moi depuis la mise à jour du 16/04/2019
Dès que je lance Utorrent, reboot en boucle... j'ai désactivé la 4G et plus ce pb mais plus de 4G aussi :-) !!

Avant cette mise à jour, je n'avais aucun souci avec l'agrégation : 5 Mo/s versus 3.7 Mo/s en VDSL seul

Maxime Bizon (mbizon)
Thursday 25 April, 2019 19:46:45

Bonjour,

Les personnes affectées pour qui ça plante avec les torrent, est ce que vous êtes connectés en ethernet ou en wifi ?

Merci

cedric (frcydrex)
Thursday 25 April, 2019 19:54:46

Ethernet pour moi, bonne idée, j'ai pas essayé, je test demain matin

Rioux yann (furnet)
Thursday 25 April, 2019 19:59:44

Bonsoir,
Pour mon cas je suis en WiFi.
Je n'ai pas essayé en rj45.
Je vais essayer demain.
Bon courage

Ultraboss (Ultraboss)
Thursday 25 April, 2019 20:39:52

Bonsoir, mon pc est en Ethernet.

Philippe VILMINT (DarwinZ69)
Thursday 25 April, 2019 20:40:15

@mbizon en Ethernet pour info ça marchait avant la mise a jour en 4.0.5

sebastien (yellowcox)
Thursday 25 April, 2019 20:45:21

Bonsoir,

En wifi pour ma part, je n'ai pas essayé en ethernet

LARDENNOIS (Squirrel71)
Thursday 25 April, 2019 21:15:43

De mon côté en Ethernet

Maxime Bizon (mbizon)
Thursday 25 April, 2019 21:20:31

J'ai passé plusieurs jours à essayer de reproduire le problème ici et je n'y arrive pas, pourtant j'ai l'impression d'avoir tout essayé, wifi/ethernet/torrent/iperf/...

Si quelqu'un a un setup qui reproduit le crash de façon certaine et immédiate, est ce qu'il pourrait le décrire ? Idéalement en retirant tous les éléments qui ne sont pas nécessaire pour faire planter, par exemple si ça plante en ethernet, s'assurer qu'il n'y a qu'une machine connectée, que le wifi est coupé, etc

Si vous pouviez également me dire sur quel OS vous êtes ? (enfin la machine qui semble provoquer le problème)

merci

LARDENNOIS (Squirrel71)
Thursday 25 April, 2019 21:24:09

Ethernet machine seule ou non, windows 10

De manière systématique, au lancement d'un téléchargement d'un torrent, la box se met à rebooter, uniquement depuis la mise à jour du 16/04

Merci

LARDENNOIS (Squirrel71)
Thursday 25 April, 2019 21:24:54

En désactivant l'agrégation 4G, plus de souci

Maxime Bizon (mbizon)
Thursday 25 April, 2019 21:51:14

@lardennois

j'ai fait un firmware bêta pour votre Freebox; si vous pouviez essayer, j'ai rajouté des logs et un correctif possible mais c'est un test à l'aveugle.

sebastien (yellowcox)
Thursday 25 April, 2019 21:52:55

Bonsoir,

Toutes les 2 minutes depuis le FW 4.0.5, sous Ubuntu 18.04, en wifi, le téléchargement d'un torrent avec le logiciel Transmission fait rebooter le Freebox server.
Rien d'autre sur le réseau à part le Freebox player branché en ethernet

Maxime Bizon (mbizon)
Thursday 25 April, 2019 22:00:12

@sebastien

ça plante également avec le freebox player débranché ?

sebastien (yellowcox)
Thursday 25 April, 2019 22:19:28

@mbizon

Oui, ça plante avec le Freebox player débranché, mais nouveauté:
le Freebox server a rebooté, est toujours à l'étape 1, mais je suis toujour connecté en wifi et ça télécharge toujours...
PS: Je n'ai plus accès à Freebox OS mais j'ai pu écrire ce message, Freebox en étape 1

Maxime Bizon (mbizon)
Thursday 25 April, 2019 22:24:23

@sebastien

pourriez vous me donner votre adresse MAC que je vous passe en beta svp ?

sebastien (yellowcox)
Thursday 25 April, 2019 22:27:17

@mbizon

34:27:92:64:23:06

Maxime Bizon (mbizon)
Thursday 25 April, 2019 22:33:29

@sebastien

vous êtes en bêta, si vous pouviez me dire si ça plante toujours... j'ai d'autres pistes mais je dois les tester une à la fois.

sebastien (yellowcox)
Thursday 25 April, 2019 22:45:54

@mbizon

Même comportement: reboot du server avec la version 4.0.5.3

Maxime Bizon (mbizon)
Thursday 25 April, 2019 22:47:06

@sebastien

merci pour le test, visiblement ça plante toujours

est ce que vous devez faire des actions manuelles pour reconnecter votre PC et provoquer le crash ou ça se fait tout seul ? si ça crash tout seul, j'emprunterai bien votre connexion pendant que vous dormez pour chercher le problème

Rioux yann (furnet)
Thursday 25 April, 2019 23:05:59

Je suis la conversation.
@mbizon
Desirez vous un second avis ?
Je peux prendre qq minutes pour essayer des tests en WiFi/rj45 ?

Maxime Bizon (mbizon)
Thursday 25 April, 2019 23:06:47

@all

si quelqu'un n'utilise pas sa connexion durant la journée de demain et peut la laisser dans un état qui provoque le crash en boucle sans intervention manuelle, ça me permettrait de trouver le problème. laissez votre MAC si c'est possible

merci

Maxime Bizon (mbizon)
Thursday 25 April, 2019 23:08:34

@furnet

non visiblement le bug n'est pas lié à l'ethernet ni au wifi mais a un pattern de trafic que je n'arrive pas à reproduire ici.

je vais aller me reposer et je reprendrai demain, en espérant avoir une box affectée dispo pour debug

Rioux yann (furnet)
Thursday 25 April, 2019 23:09:04

Aie sorry vacances scolaires. J'ai les enfants qui sont tablettes et TV. Moi je bosse de la maison.
Malheureusement je ne peux pas aider.

sebastien (yellowcox)
Thursday 25 April, 2019 23:10:17

@mbizon

Pas d'actions manuelles pour la reconnexion, envoyez moi un mail et je pourrais vous faire un environnement virtuel sur mon PC pour vos tests si vous voulez.

Maxime Bizon (mbizon)
Thursday 25 April, 2019 23:12:38

@sebastien

super merci, le mail est parti

je rentre dormir.

Nicolas (NicolasToulouse)
Friday 26 April, 2019 09:07:02

Pour moi, bug quand:

VPN activé ou non
Connexion Ethernet du PC
Player allumé ou éteind
La seule variante qui déclenche tout c'est quand les 2 critères suivants sont activés:
Agrégation 4G
Téléchargement d'un Torrent
(surement du au déclenchement de l'agrégation 4G car en VDSL "seul" le téléchargement fonctionne parfaitement sans reboot)

rr (rr)
Friday 26 April, 2019 09:24:06

@NicolasToulouse
Si tu lances le téléchargement du torrent directement via mafreebox.freebox.fr : est-ce que ça déclenche aussi un reboot ?

Sinon, je pense que si tu peux préciser
- la version de Windows,
- le client torrent que tu utilises,
- et même si tu pouvais partager un torrent qui déclenche le reboot chez toi
ça pourrait peut-être aider @mbizon à reproduire le problème plus rapidement ?

Rioux yann (furnet)
Friday 26 April, 2019 09:42:02

bonjour,

@mbizon :
j'ai eu ce matin un reboot du serveur. Voici ce que je faisais à ce moment là.
le player était allumé sur la station radio Virgin Radio (connecté en wifi sur antenne 5G)
Mon PC (windows 10) en Wifi sur antenne 5G (utilisation classique)
1 Iphone connécté au Wifi sur antenne 5G (utilisation normal, surf internet, messagerie Whatsapp, Facebook)
1 IPad connecté au wifi sur antenne 5G (aucun trafic car pas utilisé)
1 Huawei P20 lite au wifi sur antenne 2.4G (aucun trafic car pas utilisé)
1 Chuangmi-cam (Xiaomi) au wifi sur antenne 2.4G (aucun trafic car pas utilisé)
1 lumi-gateway (Passerelle Xiaomi) sur antenne 2.4G (aucun trafic car pas utilisé)

J'ai activé mon VPN. j'ai travaillé moins de 10 minutes dessus.
J'ai lancé 3 pages internet et c'est pile à ce moment là que le reboot a eu lieu.
Pas de Torrent, pas de téléchargement.

bon courage

LARDENNOIS (Squirrel71)
Friday 26 April, 2019 11:01:55

Bonjour Maxime

suite à votre message d'hier soir (21h51), vous avez besoin de mon MAC pour lancer le test ?
Si oui, le voici :

N° MAC FREEBOX - 34:27:92:61:C8:D2

Merci
Hervé

Maxime Bizon (mbizon)
Friday 26 April, 2019 12:07:59

Merci à tous pour vos indications et particulièrement à sebastien pour le setup mis à dispo pour le debug!

le problème est identifié, je prépare un nouveau firmware très rapidement.

Jack G (Gjack974)
Friday 26 April, 2019 13:51:24

bonjour a tous , apres avoir lu tout vos commentaires, il y a un point commun qui revient souvent c'est le protocole torrent.
j'ai fait le test , j'ai activé l’agrégation 4G sur la box pendant 1h et pas de reboot , dés que j'ai lancé le client Torrent (Utorrent)+ un fichier à télécharger sur mon PC, la box a rebooté direct.
C'est bien le protocole Torrent + agrégation 4G qui cause le reboot de la BOX.
j'ai refait un test 4g activé + téléchargement d'un fichier sur internet et la pas de reboot.

Maxime Bizon (mbizon)
Friday 26 April, 2019 13:58:35

voila le firmware 4.0.5.1 est dispo

Chargement...