Freebox Server (Delta V7 / Revolution V6 / Server Mini 4K)

  • État Close
  • Type de tâche Anomalie
  • Catégorie WAN → Agrégation 4G
  • Assignée à Maxime Bizon (mbizon)
  • Système d'exploitation Freebox Server V7 (Delta)
  • Sévérité Basse
  • Priorité Normale
  • Basée sur la version 4.0.2
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Server (Delta V7 / Revolution V6 / Server Mini 4K)
Ouverte par Vincent Ducros (Zurtog) - 01/01/2019
Dernière édition par Maxime Bizon (mbizon) - 16/01/2019

FS#23806 - Accès externe non fonctionnel si agrégation activé

Bonjour

FW serveur en version 4.0.3

il me semble avoir vu des sujets similaires ouverts sur le tracker du player mais pas sur celui du serveur, et ma compréhension serait plutôt que ce défaut serait plus lié au serveur

Agrégation 4G activée
- IP externe différente de l’IP en VDSL seul (IP 4G ?)
- depuis le réseau interne il est impossible de se connecter au reseau interne en passant par mon IP 4G
- depuis le réseau interne il est impossible de se connecter à un serveur interne en passant par le nom de domaine xxxx.freeboxos.fr
- depuis le réseau interne si je ping mon nom de domaine xxxxx.freebox.fr je tombe sur mon ip en VDSL seul

Agrégation 4G non activée:
- IP externe du VDSL seul (meme IP VDSL que depuis ma freebox V6)
- depuis le réseau interne tous mes accès vers le réseau interne en passant par l’IP externe (ou nom de domaine xxx.freeboxos.Fr) fonctionnent.
- depuis le réseau externe tous mes accès vers le réseau interne fonctionnent.

Contournement provisoire:
- Désactivation de l’agrégation 4G

Est-il normal d’avoir deux IP externes différentes si agrégation 4G activé ou non ?

Close par  Maxime Bizon (mbizon)
Wednesday 16 January, 2019 13:06:24
Raison de clôture :  Résolu
Commentaires supplémentaires de clôture :  en 4.0.4

Cette tache ne dépend pas d'autre tache

Nemhome (Nemhome)
Tuesday 1 January, 2019 14:38:31

Problème de loopback oui, déjà énoncé dans certains tickets? C'est assez embêtant en tout cas pour moi.

Maxime Bizon (mbizon)
Wednesday 2 January, 2019 15:11:40
Est-il normal d’avoir deux IP externes différentes si agrégation 4G activé ou non ?

oui, mais l'IP xDSL reste fonctionnelle pour les services entrants.

dans votre liste:

- depuis le réseau interne il est impossible de se connecter à un serveur interne en passant par le nom de domaine xxxx.freeboxos.fr

si c'est confirmé, je vais corriger

- depuis le réseau interne il est impossible de se connecter au reseau interne en passant par mon IP 4G

les redirections de ports ne sont pas actives sur l'ip 4G, la plage de port n'est même pas la même alors ce ne sera pas implémenté

votre DNS en .freeboxos.fr pointera toujours vers votre IP dsl

Maxime Bizon (mbizon)
Wednesday 2 January, 2019 17:01:46
si c'est confirmé, je vais corriger

ok corrigé dans le prochain firmware.

Vincent Ducros (Zurtog)
Wednesday 2 January, 2019 17:21:46

Merci pour la prise en compte de cette anomalie

Par contre il serait pas mal de mieux communiquer sur le fait qu'en agregation il y a bien deux IP (xDSL et 4G) mais que seul l'ip xDSL doit etre prise en compte pour les acces depuis l'exterieur

Ou alors il faudrait cacher l'ip 4G, car en agrégation, quand on fait un test depuis le réseau interne vers un service externe du genre mon-ip.com on tombe sur notre ip 4G et donc ça provoque de la confusion par la suite.

En tout cas pour moi c'est plus clair maintenant.

Vincent (Bedeau)
Wednesday 16 January, 2019 12:44:35

Bonjour,

Suite à la fermeture du ticket 24358 (https://dev.freebox.fr/bugs/task/24358#comment95670), je suis tombé sur celui-ci.

Pour ma part, avec la version 4.0.3, les redirections de port fonctionnent avec la 4G activé et avec l'IP de la xDSL.

Ce qui ne fonctionne toujours pas en revanche, c'est le loopback (depuis le réseau interne il est impossible de se connecter à un serveur interne en passant par le nom de domaine xxxx.freeboxos.fr). Impossible par exemple d'avoir accès à la freebox via l'adresse : https://xxxxx.fbxos.fr:28218/login.php quand je suis connecté au wifi à la maison.

D'autres personnes peuvent confirmer ?

Merci
Vincent

Nemhome (Nemhome)
Wednesday 16 January, 2019 12:49:09

Je confirme: redirection de port fonctionnelle, mais loopback ne fonctionne pas. Autre soucis du même genre : l'adresse IP sortant, en 4G activé, est celle de Free Mobile et non notre IP fixe ce qui peut être gênant : par exemple, j'ai un serveur mail sécurisé, et le DNS MX a été construit autour de mon adresse IP xDSL. Lorsque j'active la 4G, je ne peux plus envoyer de mail (ils sont soit e n SPAM, soit refusé car l'adresse IP du serveur d'envoi n'est pas celle qui correspond au MX.)

Vincent (Bedeau)
Wednesday 16 January, 2019 13:01:47

Merci de ce retour, en espérant que cela évolue rapidement...

Vincent

Chargement...