Freebox Server (Ultra V9/ Pop V8/ Delta V7 / Revolution V6 / Mini 4K)

  • Status Nouveau
  • Percent Complete
    0%
  • Task Type Anomalie
  • Category LAN
  • Assigned To No-one
  • Operating System Freebox V9 (Ultra)
  • Severity Low
  • Priority Very Low
  • Reported Version 4.7.9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Freebox Server (Ultra V9/ Pop V8/ Delta V7 / Revolution V6 / Mini 4K)
Opened by Kalel - 15/04/2024
Last edited by Kalel - 15/04/2024

FS#39336 - Connexion 2.5G avec un adaptateur Solo 10G impossible

Bonjour,
Je vous donne mon retour utilisateur sur une connexion sur les ports 2.5G d’une Freebox Ultra, impossible de mettre en route la connexion 2.5G
avec un adaptateur SONNETECH SOLO 10G sur Mac OSX Sonoma 14.4.1 alors que tout fonctionne sans problème sur le port 2.5G d’une Freebox Pop.

La connexion en 1G fonctionne mais quand je modifie les paramètres d’autonégotiation des ports ethernet du Freebox Server en 2.5G la connexion se coupe.

J’ai testé tout ça sur tous les ports 2.5G de la Freebox Ultra et avec des câbles ethernet catégorie 7 en direct sans switch intermédiaire.

Pour info cette connexion 2.5G d’une Freebox Ultra sur Mac OSX Sonoma 14.4.1 fonctionne très bien maintenant mais avec un adaptateur Belkin Adaptateur USB-C vers Ethernet 2,5 Gbit/s.

Donc problème de compatibilité avec l’adaptateur SONNETECH SOLO 10G, bug à corriger je pense vu que la connexion 2.5G avec cette adaptateur fonctionne très bien avec une Freebox Pop.

Merci.

Cordialement,
Laurent

C'est normal il n'est pas multi Gig, il fait que du 10G

Admin

Bonjour,

Est-ce que vous pouvez vérifier dans FreeboxOS la vitesse du lien lorsque vous vous connectez avec l'adaptateur Solo 10G ?

Idem côté Mac.

De mon côté, le lien monte bien 2.5Gbps et un test iperf affiche bien les débits attendus (avec un PC linux).

Kalel commented on 15.04.2024 14:53

Bonjour @docmarc

Merci mais je ne suis pas d'accord car fonctionne très bien en 2.5G avec une Freebox Pop sur le port 2.5G.

Bonjour @mmakassikis Vitesse du lien avec Speed Test Download : 929 Mbps et Upload : 928 Mbps

Pour info j'ai tout essayé cet adaptateur SONNETECH SOLO 10G sur Mac OSX Sonoma 14.4.1 ne fonctionne pas en 2.5G mais bien 1G

Kalel commented on 15.04.2024 15:03

@docmarc

Ici les informations qui montre bien que cet adaptateur est bien compatible 2.5G :
https://www.sonnettech.com/product/solo10g-tb3/overview.html

“Supports NBASE-T Standard - 5 Gb/s and 2.5 Gb/s speeds supported over inexpensive Cat 5e (or better) cabling at distances up to 100 meters when used with a multi-Gigabit switch or router.”

Et ici aussi :
https://www.macway.com/sonnet-solo-10g-adaptateur-thunderbolt-3-vers-10-gigabit-ethernet/p868838?s_kw=solo%2010g&oid=397494

“Les points forts
Adaptateur 10 Gigabit Ethernet
Compatible Ethernet 5G, 2,5G, 1G, 100M
Auto-alimenté par le port Thunderbolt 3
Compatible Mac & PC”

Kalel commented on 15.04.2024 15:05

Après plusieurs tests (différents Mac utilisés), mon diagnostic est que la Freebox Ultra a un problème avec cet adaptateur, car essayé avec le Freebox Pop est ça fonctionne sans problème

Kalel commented on 15.04.2024 15:08

En tout cas merci pour vos réponses @docmarc et @mmakassikis

Admin

Par vitesse du lien, je pensais à la vitesse de lien négocié, plutôt que le débit atteignable en test.

Dans FreeboxOS, c'est dans Paramètres > Mode avancé > Switch.

Kalel commented on 16.04.2024 08:25

Bonjour @mmakassikis

Quand je choisi 2500BaseT-FD en vitesse de lien négocié dans Paramètres > Mode avancé > Switch la connexion se coupe.

Aucun problème en 1000BaseT-FD.

Admin

Par défaut, l'autonegotiation indique les différents modes supportés et les deux pairs (box / pc) prennent le dénominateur commun.

En indiquant 2500BaseT-FD, il y a toujours autoneg, mais la box ne présente *que* le mode en question. Si le lien ne s'établie pas, c'est qu'il n'y a pas de dénominateur commun.

Si cela fonctionne en 1000BaseT-FD, cela suggère que votre mac ne présente rien au dessus. Il faudrait vérifier sur celui-ci s'il n'y a pas une configuration dans ce sens.

Juste pour info :
La prise en charge des vitesses de liaison 5 Gb/s et 2.5 Gb/s nécessite un commutateur compatible NBASE-T (multi-Gigabit).

https://manuals.plus/fr/sonnet/solo10g-thunderbolt-3-edition-manual

Kalel commented on 16.04.2024 10:28

Bonjour @docmarc Vu que ça fonctionne sur la Freebox Pop j'en conclu que la Freebox Pop est compatible NBASE-T mais pas la Ultra ?

je ne sais pas pour l’ultra, mais pour avoir installé plusieurs versions du sonotech.
le sonotech est très capricieux avec realtek et encore pire sur intel en mode 2.5

j'ai dû tous les configurer en 10G a travers un routeur dédié

pour être sûr que ce soit l'ultra en cause je revérifierai certaine chose avant

que ma Compatibilité Mac® est correct »

  Mac avec ports Thunderbolt 3
  MacOS® 10.13.6+
  Compatible macOS Mojave

Que le câble [câble CAT 6A, CAT 6] soit pas trop ancien les câbles peuvent s'oxyder et du jour au lendemain ne plus être à la norme de performance requis.

ses deux points semblent être OK pour toi

je vérifierai que les Étapes de réglage des performances – macOS sont respectés
(voire manuel sonotech)
https://manuals.plus/fr/sonnet/solo10g-thunderbolt-3-edition-manual#driver_information

et là on pourra dire qu'effectivement que l'ultra a un problème


je laisse le reste du diagnostique a @mmakassikis

Admin

Ce n'était peut être pas clair dans mon premier message, mais j'ai fait le test avec un Solo 10G (laptop → Solo 10G en thunderbolt → cable ethernet vers un port Ethernet de l'ultra) et le lien monte bien en 2.5Gbps.

Le laptop est sous Linux, donc driver différent de celui de votre mac mais autrement niveau hardware pas d'incompatibilité entre le Solo et l'Ultra.

Avez-vous un périphérique non Apple pour tester ?

Kalel commented on 16.04.2024 12:49

@mmakassikis

Merci, non pas de périphérique non Apple pour tester.

De toute façon vu que ça fonctionne bien en 2.5G avec Mac + Solo 10G + Freebox POP, pour moi le problème vient de la Freebox ULTRA qui doit avoir quelque chose de différent de la POP.

Kalel commented on 16.04.2024 12:57

@docmarc Tous mes câbles sont neufs, je suis avec un MacBook Pro M3 Max en 14.4.1 et en Thunderbolt 4 de dernière génération

Et j'ai bien essayé tout ça avant de vous reporter le problème, rien à faire :
Étapes de réglage des performances – macOS
Vous trouverez ci-dessous les étapes nécessaires pour configurer l'adaptateur Solo10G pour des performances maximales. Veuillez noter que pour prendre de l'avancetage de ces paramètres, le commutateur ou le routeur auquel l'adaptateur est connecté doit également prendre en charge ces fonctionnalités.

Ouvrez les Préférences Système, puis cliquez sur Réseau. Dans le panneau Préférences réseau, cliquez sur l'adaptateur Solo10G (Thunderbolt Ethernet, Slot x) dans le panneau de gauche, puis cliquez sur Avancé ; un nouveau panneau apparaît.
Dans le nouveau panneau, cliquez sur Matériel. Dans le menu déroulant Configurer, sélectionnez « Manuellement ». Dans le menu déroulant Vitesse, laissez le paramètre sur ou sélectionnez "10GbaseT" (ou "5000baseT" ou "2500baseT" si l'un ou l'autre est la vitesse maximale prise en charge par votre connexion réseau). Dans le menu déroulant Duplex, sélectionnez « duplex intégral » (pas « duplex intégral, contrôle de flux »). Dans le menu déroulant MTU, sélectionnez « Jumbo (9000) » ou sélectionnez « Personnalisé », puis entrez « 9000 » dans la case ci-dessous.
Lorsque vous avez terminé de modifier les paramètres, cliquez sur OK.
De retour dans la fenêtre principale du réseau, cliquez sur Appliquer après avoir terminé de modifier les paramètres.

Kalel commented on 16.04.2024 12:58

Sinon est-ce quelqu'un peut essayer sur un Mac et non Linux ?

Moi j'ai essayé avec mes deux macs et rien à faire avec la Ultra

Admin

Avez-vous modifié ces "réglages de performances" ?

Kalel commented on 16.04.2024 13:14

@mmakassikis Si les réglages de performances sont ce que je vient de vous copier/coller ci-dessus, alors oui j'ai essayé ;)

Admin

Il faudrait tester en 2500baseT, duplex intégral contrôle de flux sans toucher au MTU

Kalel commented on 16.04.2024 13:51

Déjà fait

Kalel commented on 16.04.2024 13:54

Avec n'importe quel réglage de performances du Mac la connexion coupe tout le temps quand je modifie les paramètres d’autonégotiation des ports ethernet du FreeboxOS en 2500BaseT-FD, dans Paramètres > Mode avancé > Switch.

Kalel commented on 16.04.2024 13:55

Je suis désolé mais je n'aurais pas ouvert ce ticket si je n'avais pas tout essayé avec ce que j'ai comme matériel

Admin

Testé sur le macbook d'un collègue (M2, Sonoma 14.4).

A la connexion, l'OS demande de confirmer que l'on souhaite utiliser le périphérique Solo 10G.

Dans les paramètres réseaux, sont bien visibles l'adresse IP et le type de lien négocié (2500BaseT). Les paramètres avancés des périphériques Thunderbolt & Ethernet:

Aquantia AQC107 :
 Bus :	PCI
 Identifiant du fournisseur :	0x1d6a
 Identifiant du périphérique :	0x87b1
 Identifiant du fournisseur du sous-système :	0x16b8
 Identifiant du sous-système :	0x72e1
 Identifiant de révision :	0x0002
 Vitesse de la liaison PCIe :	8.0 GT/s
 Largeur de la liaison PCIe :	x4
 Logement PCIe :	Thunderbolt@3,0,0
 Version du programme interne :	3.1.121
 Gestionnaire :	com.apple.driver.AppleEthernetAquantiaAqtion
 Nom de périphérique BSD :	en10
 Adresse MAC :	00:30:93:10:67:36
 Prise en charge AVB :	Oui
 Vitesse maximale de la liaison :	10 Gbit/s
Solo 10G Thunderbolt 3 Edition :
 Nom du fournisseur :	Sonnet Technologies, Inc
 Nom du périphérique :	Solo 10G Thunderbolt 3 Edition
 Mode :	Thunderbolt 3
 Identifiant du périphérique :	0x34
 Identifiant du fournisseur :	0x8
 Révision du périphérique :	0x1
 UID :	0x0008680E18B99600
 Chaîne de routage :	1
 Version du programme interne :	33.1
 Port (amont) :
 État :	Périphérique connecté
 État du lien :	0x2
 Vitesse :	Jusqu’à 40 Gbit/s x1
 Largeur du lien actif :	0x2
 Version du programme interne du contrôleur de liaison :	0.35.0

Côté box, le lien est bien monté en 2500BaseT dans Paramètres > Mode avancé > Switch. Il n'y a pas de configuration à faire, le paramétrage par défaut suffit (d'ailleurs, il y a rarement besoin de toucher aux paramètres d'autonégotiation).

Un test nperf confirme bien les débits de 2.5Gbps.

Kalel commented on 16.04.2024 14:31

Je suis d'accord il n'y a rarement besoin de toucher aux paramètres d'autonégotiation.

Merci pour vos tests, pas exactement la même config que moi mais ça montre que ça peut fonctionner

Voilà ce que j'ai de mon côté :

Ici menu Thunderbolt :
Solo 10G Thunderbolt 3 Edition :

Nom du fournisseur :	Sonnet Technologies, Inc
Nom du périphérique :	Solo 10G Thunderbolt 3 Edition
Mode :	Thunderbolt 3
Identifiant du périphérique :	0x34
Identifiant du fournisseur :	0x8
Révision du périphérique :	0x1
UID :	0x0008F39521604400
Chaîne de routage :	1
Version du programme interne :	33.1
Port (amont) :
État :	Périphérique connecté
État du lien :	0x2
Vitesse :	Jusqu’à 40 Gbit/s x1
Largeur du lien actif :	0x2
Version du programme interne du contrôleur de liaison :	0.35.0

Et ici pour le menu PCI :
Aquantia AQC107 :

Nom :	ethernet
Type :	Contrôleur Ethernet
Gestionnaire installé :	Oui
Compatible avec les tunnels :	Oui
Pause possible :	Oui
MSI :	Oui
Bus :	PCI
Logement :	Thunderbolt@3,0,0
Identifiant du fournisseur :	0x1d6a
Identifiant du périphérique :	0x87b1
Identifiant du fournisseur du sous-système :	0x16b8
Identifiant du sous-système :	0x72e1
Identifiant de révision :	0x0002
Largeur du câble :	x4
Vitesse de la liaison :	8.0 GT/s
Kalel commented on 16.04.2024 14:32

Ici menu réseau :
Solo 10G :

Type :	Ethernet
Matériel :	Ethernet
Nom de périphérique BSD :	en7
IPv4 :
Méthode de configuration :	DHCP
IPv6 :
Adresses :	2a01:e0a:X:Y, 2a01:e0a:X:Z
Méthode de configuration :	Automatique
Nom confirmé de l’interface :	en7
Nom de l’interface :	en7
Signature réseau :	IPv6.Prefix=2a01:e0a:X::/64;IPv6.RouterHardwareAddress=38:07:16:c2:bf:99
Longueur du préfixe :	64, 64
Routeur :	fe80::3a07:16ff:fec2:bf99
DNS :
Adresses du serveur :	fd0f:ee:b0::1
Ethernet :
Adresse MAC :	00:30:93:10:39:fb
Options Média :	Duplex intégral
Sous-type Média :	1000baseT
Proxys :
Liste de exceptions :	*.local, 169.254/16
Mode FTP passif :	Oui
Proxys de suspension d’activité :

1 HomePod Mini Kalel :

Puissance marginale :	60
Métrique :	703560
Portabilité :	35
Puissance totale :	63
Type :	70

1 Apple TV Kalel 4K 2021 :

Puissance marginale :	60
Métrique :	703560
Portabilité :	35
Puissance totale :	63
Type :	70
Ordre des services :	1
Admin

Chez vous:

Gestionnaire installé :	Oui

Sur la machine de mon collègue:

 Gestionnaire :	com.apple.driver.AppleEthernetAquantiaAqtion

Avez-vous installé du soft spécifique ?

Kalel commented on 16.04.2024 14:47

Ici réglage Ethernet :
Aquantia AQC107 :

Bus :	PCI
Identifiant du fournisseur :	0x1d6a
Identifiant du périphérique :	0x87b1
Identifiant du fournisseur du sous-système :	0x16b8
Identifiant du sous-système :	0x72e1
Identifiant de révision :	0x0002
Vitesse de la liaison PCIe :	8.0 GT/s
Largeur de la liaison PCIe :	x4
Logement PCIe :	Thunderbolt@3,0,0
Version du programme interne :	3.1.118
Gestionnaire :	com.apple.driver.AppleEthernetAquantiaAqtion
Nom de périphérique BSD :	en7
Adresse MAC :	00:30:93:10:39:fb
Prise en charge AVB :	Oui
Vitesse maximale de la liaison :	10 Gbit/s
Kalel commented on 16.04.2024 14:49

Différence version programme interne

Chez moi : Version du programme interne : 3.1.118

Chez vous : Version du programme interne : 3.1.121

Admin

Effectivement. D'après la doc sonnet:

Description: This firmware fixes a few issues with Windows and Linux, however, the firmware updater runs only under Windows. macOS loads virtual firmware as part of its initialization of the Solo10G, so in most cases, it generally does not matter which version of firmware is programmed into the Solo10G when you are using macOS. If you have initialization issues that cannot be otherwise explained, consider updating the firmware.

http://www.sonnettech.com/support/kb/kb.php?cat=537&expand=_a3_b1031_a2_a13_b1015_b1044_b1018&action=b1063#b1063

C'est un peu contradictoire quand même: pas d'impact normalement, mais si il y a des problèmes, il vaut mieux faire la mise à jour …

Kalel commented on 16.04.2024 14:58

Je viens de demander la mise à jour Firmware 1.80.3_3.1.121a pour OSX à Sonnetech car je ne trouve que la version Windows ici:
https://www.sonnettech.com/support/kb/kb.php?cat=537&expand=_a3_a13_a2&action=a2#a2

Kalel commented on 16.04.2024 14:59

Bon ce qui est quand même bizarre c'est que cela fonctionne sans problème sur la Freebox Pop ?

Vous en pensez quoi @mmakassikis ?

Kalel commented on 16.04.2024 16:28

@mmakassikis Et sinon je n'ai pas installé de soft spécifiques

Kalel commented on 17.04.2024 08:07

Bonjour @mmakassikis Vous pouvez voir aussi que dans mes réglages Ethernet, j'ai aussi le gestionnaire “com.apple.driver.AppleEthernetAquantiaAqtion”

Aquantia AQC107 :

Bus :	PCI
Identifiant du fournisseur :	0x1d6a
Identifiant du périphérique :	0x87b1
Identifiant du fournisseur du sous-système :	0x16b8
Identifiant du sous-système :	0x72e1
Identifiant de révision :	0x0002
Vitesse de la liaison PCIe :	8.0 GT/s
Largeur de la liaison PCIe :	x4
Logement PCIe :	Thunderbolt@3,0,0
Version du programme interne :	3.1.118
Gestionnaire :	com.apple.driver.AppleEthernetAquantiaAqtion
Nom de périphérique BSD :	en7
Adresse MAC :	00:30:93:10:39:fb
Prise en charge AVB :	Oui
Vitesse maximale de la liaison :	10 Gbit/s
Kalel commented on 17.04.2024 08:09

Et sinon pour la mise à jour du firmware sur Mac, Sonnetech m'a dit de me rapprocher de Marvell, le fabriquant du Aquantia AQC107.

J'attends leur réponse.

Mais pour moi le problème vient de la ULTRA, vu que cela fonctionne avec la POP

Kalel commented on 17.04.2024 08:28

Peux t'on avoir un rapport de l'activité d'une Freebox Ultra sur Freebox OS ?

Pour voir ce qu'il est noté quand je passe en 2500BaseT-FD en vitesse de lien négocié dans Paramètres > Mode avancé > Switch

Merci ;)

Kalel commented on 19.05.2024 19:41

Bonjour,
Suite de mes tests de la compatibilité Solo 10G avec Freebox Ultra sous MacOS X Sonoma 14.5, j'ai reçu mon adaptateur SFP+ vers RJ45 et là pas de problème j'ai bien une connexion 10G.

Donc pour moi il y a bien un problème avec la Freebox Ultra + SOLO 10G sous MacOS X Sonoma 14.5 et la connexion 2.5G qui n'a jamais fonctionné sur ma machine MacBook Pro M3 Max.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing