Freebox Player (Revolution / V6)

  • État Nouveau
  • Type de tâche Anomalie
  • Catégorie Lecteur multimédia
  • Assignée à Personne
  • Système d'exploitation Tous
  • Sévérité Basse
  • Priorité Normale
  • Basée sur la version 1.3.18
  • Due pour la version Non décidé
  • Date d'échéance Non décidé
Concerne le projet: Freebox Player (Revolution / V6)
Ouverte par julien (julien1486) - 30/04/2016

FS#20196 - [Playlist] Ne passe pas à la vidéo suivante si j'enlève les sous-titres

Bonjour,

J’ai constaté le bug aujourd’hui, mais je ne sais pas s’il est dû à la dernière version.
J’ai un dossier avec plusieurs dizaines de fichiers .mkv (Livre 2 Kaamelott). Dans chaque fichier j’ai une seule piste audio et j’ai une piste de sous-titres (audiodescription) qui est active par défaut.

Ce que je fais :

  1. Depuis le menu Mes Disques/Disque Dur/Téléchargements je vais dans le répertoire contenant mes fichiers.
  2. Je sélectionne un fichier au hasard dans la liste
  3. La lecture du fichier démarre, je constate la présence des sous-titres : j’ouvre le menu contextuel ⇒ Langues et sous-titres : je sélectionne “Pas de sous-titres”
  4. J’appuie sur le bouton rouge de la télécommande “retour”
  5. je vais dans le menu “Mode de lecture” et je sélectionne “Aléatoire”

Déjà je constate que le mode “Une seule” reste sélectionné, je ne sais pas si c’est normal
Ensuite, je constate le bug dans l’un et l’autre des deux cas suivants :

  • J’attend la fin de la vidéo pour avancer dans la Playlist
  • Je sélectionne une autre vidéo via le menu “Playlist”

Dans ces deux cas : La lecture de la vidéo suivante ne démarre pas et l’écran est noir. Si j’appuie sur la touche jaune “Infos”, j’ai bien en bas le nom de la vidéo suivante, mais le temps affiché est de 00:00:00 et la barre de progression infinie (tout en bas à gauche) tourne indéfiniment.
Je dois faire “Retour” plusieurs fois pour retourner à la liste de mes fichiers.

J’ai testé d’autres scenarii :

  • Le bug se produit également si je sélectionne le mode de lecture “Dans l’ordre”.
  • J’ai constaté que si je n’enlevais pas les sous-titres les vidéos s’enchaînent bien (même si le choix “Une seule” reste sélectionné) et ce, quelque soit le mode Aléatoire/Dans l’ordre.


J’ai redémarré le player via le menu général (Touche “Free” ⇒ Réglages/Système/Redémarrer le Freebox Player) sans que cela ne règle le problème.

Je ne sais pas si c’est la même cause auquel cas je pourrais créer une nouvelle tâche :
Une autre fois j’ai constaté qu’après avoir lancé la lecture d’une vidéo suivante (donc n’ayant pas au préalable désactivé les sous-titres de la vidéo initiale sinon la vidéo suivante ne se serait pas lancé), ayant voulu enlever les sous-titres (ouais je teste plein de trucs, déformation professionnelle) j’ai constaté un bug dans le menu contextuel “Langues et sous-titres” : La partie “Audio” affiche la piste audio de la vidéo mais elle n’est pas sélectionnée, et la partie “Sous-titres” affiche la piste de sous-titre disponible mais “Pas de sous-titre est sélectionné” alors que les sous-titres sont bien affichés : Lien vers une photo.

A votre disposition pour aider à la résolution :)

Cette tache ne dépend pas d'autre tache

Chargement...