Freebox Server (Ultra V9/ Pop V8/ Delta V7 / Revolution V6 / Mini 4K)

  • Status Nouveau
  • Percent Complete
    0%
  • Task Type Anomalie
  • Category LAN
  • Assigned To No-one
  • Operating System Freebox V9 (Ultra)
  • Severity Critical
  • Priority Very Low
  • Reported Version 4.8.10
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private

FS#39503 - Lien SFP DOWN depuis la 4.8.10

Depuis la 4.8.10 le lien SFP ne monte pas même en forçant le type ! Impossible malgré redémarrage électrique d’avoir un lien opérationnel. Je sollicite donc de l’aide pour diagnostiquer le problème et si possible un contournement ou un patch rapide.

https://ibb.co/94tPWMk https://ibb.co/x5swNJf https://ibb.co/qR3gc99 Cordialement,
NP

plus de details si tu veut que les devs Free t'aide

type de modules rj45 ? marque et modele ? cable SFP actif passif ? marque et modèles?

bref un minimum

NPE commented on 31.05.2024 19:30

FiberMall SFP-10G-T-CI-80m 2.5W multi data rate 80m on cat6a (Broadcom chip)
Switch Trendnet TEG-S762 r2
https://www.fibermall.com/file/datasheet/sfp-10g-ts80.pdf

Aucune difficulté jusqu'au 4.8.8. Apparition des statistiques pour le port SFP en 4.8.9 et début des ennuis avec l'obligation de forcer le type de SFP pourtant lu dans l'EEPROM. Le passage en 4.8.10 empêche toute connexion !

NPE commented on 31.05.2024 19:42

Les paramètres du SFP sont désormais affichés même si non sauvegardables. Les vitesses proposées me semblent erronées au moins à l'affichage avec 10M,100M,1G et 2,5G sans 5G ou 10G !
Après j'ai espoir que Broadcom reparle à Broadcom … Cette version 80m a été choisie car elle permet la réception en condition difficile (prise murale) et consomme peu en tout cas moins que un SFP Marvell.

NPE commented on 01.06.2024 17:44

Aucun changement en 4.8.11 le lien SFP reste down. En connectant le cable à destination du switch sur un des ports Ethernet 2,5G de la box le fonctionnement est rétabli à cette vitesse.

NPE commented on 05.06.2024 09:07

mac 380716C10F5F

4.8.5 ok
4.8.6 ok
4.8.8 ok
4.8.9 ??
4.8.10 ko
4.8.11 ko

NPE commented on 17.06.2024 10:43

Bonjour, Après 3 semaines infructueuses, j'ai réussi ce midi à relancer le SFP en arrêtant la freebox et en le sortant de sa cage pour le laisser refroidir. J'ai ensuite rebranché électriquement la box, le SFP et le RJ45 et la liaison s'est faite immédiatement. Il est possible qu'un problème dans la gestion du SFP dans sa phase d'initialisation (statistiques en boucle ?) et/ou du ventilateur par Freebox OS soit la cause du problème.

Après en cas d'absence du domicile cette méthode pour retrouver une connexion SFP 10Gb me semble difficile. Il s'avèrerait dans ma configuration 4.8.11, DD NVME et SFP-10G-T-CI-80m qu'un redémarrage à chaud sans jeu de mots soit impossible. Une fois la liaison établie, elle semble stable à une température élevée.

NPE commented on 18.06.2024 06:26

Quelques informations complémentaires,

Lorsque la connexion est tombée avec ou sans câble Ethernet le SFP est chaud mais tenable
Lorsque la connexion s'est rétablie, il était devenu brulant et intenable
Lorsque la connexion est stable à 10Gb le SFP devient froid

Je n'ai pas pris le temps de mesurer la température au thermomètre infrarouge.

Si quelqu'un pouvait prendre des logs du 17 Juin avant, avec reboot sans débranchements, après reboot après débranchements et en fonctionnement de croisière.

NPE commented on 22.06.2024 21:37

Le bug est toujours présent dans la version 4.8.12 sortie hier. J'ai avancé dans la compréhension du problème qui est un défaut d'initialisation du module SFP+ au redémarrage à froid et à chaud. Pour refaire fonctionner celui-ci, il faut l'enlever et redémarrer sans module la box. Redémarrer ensuite une fois avec le module inséré et la liaison est up (routine d'initialisation différente?). Ce contournement est bien sûr impossible à distance et tout redémarrage intempestif de la box rendra indisponible le module SFP+ jusqu'à une intervention sur site ! Merci de corriger rapidement ce dysfonctionnement arrivé avec les statistiques.

NPE commented on 22.06.2024 21:39

J'ai un espoir étant donné la nature parfaitement reproductible du problème et de son contournement d'un retour à un fonctionnement normal.

NPE commented on 11.07.2024 18:37

Abandon de la demande, j'ai commandé et installé la version de Free un SFP-10G-T-FBX-PO au format USXGMII.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing