Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)

  • Status Closed
  • Percent Complete
    100%
  • Task Type Anomalie
  • Category Services locaux → AFP
  • Assigned To
    minico
  • Operating System Tous
  • Severity Low
  • Priority Very Low
  • Reported Version 1.1.3
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Freebox Server (Pop V8/ Delta V7 / Revolution V6 / Server Mini 4K)
Opened by pilouccio - 08/10/2011
Last edited by rfliedel - 26/05/2014

FS#8065 - AFP ne fonctionne pas lorsqu'il est activé dans la console

Le serveur AFP ne fonctionne que si on le désactive dans la console de gestion en laissant activé le partage windows ! Dans ces conditions l’icone SMB n’apparait pas (c’est peut être normal)

En revanche si on active le partage Mac OS, l’icone apparait mais le NAS n’est pas accessible...

Closed by  rfliedel
26.05.2014 21:21
Reason for closing:  Résolu
Additional comments about closing:  

En 2.1.2

Project Manager
nipo commented on 08.10.2011 18:00

http://mafreebox.freebox.fr/settings.php?page=net_lan_name permet de changer le nom de la box.
Le “Nom du Freebox Server” est celui qui apparait dans Finder,
Le “Nom DNS” est celui qui vous permet d’accéder à la box par cmd-K puis afp://nom-dns,
Le “Nom Netbios” est celui qui apparait sous windows.

nok99 commented on 09.10.2011 09:05

Le post précédent (et en particulier : afp://freebox-server) ne permet en aucun cas de résoudre cette régression supplémentaire @ laquelle nous commençons @ être habitués au fils des MàJ :(

Project Manager
nipo commented on 09.10.2011 09:38

Je n’arrive pas à reproduire chez moi le problème que vous décrivez.

Pourriez-vous donner l’état exact:
- des trois noms du Freebox Server,
- d’AFP et SMB (activation, acces public, etc).

Pourriez-vous aussi préciser:
- ce que vous attendiez,
- ce que vous avez eu à la place.

Merci

nok99 commented on 09.10.2011 09:47

http://mafreebox.freebox.fr/settings.php?page=net_lan_name :
Nom du Freebox Server : Freebox Server
Nom DNS : freebox-server
Nom Netbios : Freebox_Server

http://mafreebox.freebox.fr/settings.php?page=nas_share :
Groupe de travail : WORKGROUP
tout activé dont user+pass = pas de pb de connection via ce protocole

Paramètres des partages Mac OS http://mafreebox.freebox.fr/settings.php?page=nas_afp

accès via user+pass et la rien ne marche = impossible de faire monter le disque Nas sur le bureau via le protocole afp alors qu’avant la màj server ça marchait niqu’elle… du coup mon iTunes plante à chaque fois qu’il veut s’y connecter :’(

Pour info j’ai aussi testé sans User+pass = idem refus de connection avec 2 variantes :
-1ere variante : ça tente de se connecter, ça mouline dans le vide et sans message d’erreur ça arrête d’essayer de se connecter…
-2e variante : “le nom d’utilisateur ou le mdp sont incorrects”…

WtF O_o

nok99 commented on 09.10.2011 09:53

ah oui je passe par l'icone des disque Nas qui sont dans mes fenetres pour tenter d'y accéder et en passant par :
K afp://freebox-server
qui est le nom de ma friteuze, j'ai ça :
http://i.imgur.com/OTRzF.png

Project Manager
nipo commented on 09.10.2011 12:17

Pour afp://freebox-server/, je n’arrive pas non plus à y accéder.
Je me rends compte que le nom complet avec lequel MacOS résoud est afp://freebox-server.local/ (j’ajouterai ça dans la doc).

Pour le reste j’ai tout qui fonctionne, avec le même firmware côté Server.
Ça va être moins simple pour comprendre ce qui provoque le problème chez vous.

nok99 commented on 09.10.2011 15:35

Perso :
afp://freebox-server/
ne marche pas non plus :(

et plus étrange lorsque je fais un scan avec IP Scanner
http://itunes.apple.com/fr/app/ip-scanner/id404167149?mt=12

il ne vois plus la 2e connexion freebox (serveur mac OSX) qui, au passage, n’a pas la même adresse mac que via la connexion smb

Je confirme le même problème chez moi, depuis la dernière mise à jour :

- Si j’active le partage MAC dans la console freebox, l’icone de la freebox apparaît dans mon finder, mais si je clique dessus ça ne marche pas : “connexion en cours” indéfiniment
- Si je désactive le partage MAC, et le partage Windows, ça ne fonctionne pas non plus, mais de manière différente : “Echec de la connexion” immédiat
- Si je désactive le partage MAC, et active le partage Windows, bizarrement cela fonctionne

A noter, une bizarrerie supplémentaire :
- Dans la première config décrite, ça n’empêche pas Time Machine de faire ses backup sur un DD externe branché sur la freebox server (DD qui est pourtant inaccessible par le finder donc)
- Dans la 3e config, le DD est accessible dans le finder, mais introuvable par Time Machine
-

Une précision supplémentaire sur la 2e config décrite : quand je dis “ça fonctionne” je parle bien de l’icône du partage Mac dans le Finder
(une 2e icône pour le partage Windows fonctionne aussi par ailleurs)

Mon dernier commentaire parlait de la 3e config bien sur :)

Project Manager
nipo commented on 16.10.2011 10:02

@devanz:
- Dans le premier cas, vous avez AFP activé mais SMB pas activé. AFP semble fonctionner même si votre Finder n’arrive pas à l’afficher: Time Machine y arrive (j’avoue ne pas savoir où chercher pour le coup)
- Le 3eme cas que vous décrivez, même si Finder affiche 2 icones, elles correspondent toutes les deux à SMB, vous montez donc systématiquement la version SMB du partage. Le fonctionnement de Time Machine sur SMB est limité. C’est pourquoi ça ne fonctionne pas.

Reste donc à comprendre pourquoi Finder n’arrive pas à ouvrir le partage AFP.

Ok, ce que vous dites semble être confirmé par le fait que dans le 3e cas, même si l’icône AFP dans le finder semble fonctionner, la méthode cmd-K puis afp://freebox-server.local/ ne fonctionne pas.

Nous sommes apparemment plusieurs à avoir ce problème depuis la dernière mise à jour. Quelque chose a-t-il été modifié dans le partage AFP ?

nok99 commented on 16.10.2011 10:37

Perso depuis mon passage en OSX 10.7.2 quand :

• j’active les 2 protocoles du nas :
Windaube et Mac, il n’y en a plus qu’1 qui apparait dans la fenêtre :
http://i.imgur.com/rsVdD.png et qui n’est plus accessible :(

pour me connecter au serveur du windaube = obligé de passer par
“se connecter au serveur” vi@ :
smb://192.168.0.254

et là je peux monter le Nas en protocole Windaube :

http://i.imgur.com/k41V4.png

• Lorsque je désactive le partage Mac dans la console de gestion, seul le Nas via windaube s’affiche dans la fenêtre et quand je click dessus il monte…

Bref, grosso & modo le protocole Mac ne fonctionne plus depuis la dernière MàJ Player…

Suite à un problème sur mon Mac, j’ai dû le formater et réinstaller l’OS “nu” (sans restaurer de backup Time Machine, donc comme sorti d’usine).
Le comportement est exactement le même qu’avant, ce qui confirme que le problème vient d’une mise à jour récente de la freebox (1.1.3) ou de celle de Mac OS (10.7.2), ou des deux.

(j’utilisais Mac OS 10.7.2 en bêta depuis des mois, et cela fonctionnait très bien, ce qui laisse penser que cela vient plutôt de la freebox, sauf régression apparue sur la version finale de 10.7.2)

Bonjour à tous,

Je viens ajouter ma pierre à l’édifice, je confirme le bug chez moi.

Je suis en mesure d’effectuer mes sauvegardes Time Machine en revanche la connexion au NAS depuis le Finder ne fonctionne pas avec l’icône Airport, uniquement en partage Windows...

Dans la console d’admin mafreebox.freebox.fr j’ai bien reglé le partage de connexion mac os et l’accès invité mais rien n’y fait “connexion en cours”... et puis rien.

Par contre chez mes beaux parents aucun problème avec le même macbook, ce qui confirme bien que le problème vient du NAS de la box.

Merci d’avance aux développeurs de chez Free qui se pencheront sur le problème :)

Bonjour,

Je ne sais pas si c’est dû à la dernière version du server mais le partage AFP fonctionne normalement avec SMB désactivé (serveur, TM) .

Il reste juste une pop up “Something wrong with the volume’s CNID DB, using temporary CNID DB instead.Check server messages for details!” à la première ouverture du disque réseau.

C’est sûrement un pb de configuration netatalk. Pour les développeurs free, j’ai trouvé ça sur un forum :

“Then I looked at my configuration and there was a problem with AppleVolumes.default. You can specify a cnidscheme for each volume. You can choose between dbd (default), last and tdb. In my case the cnidscheme was set to the value cnid, which is invalid. After changing it back to dbd everything worked fine again.”

Pourquoi ne pas le corriger en implémentant netatalk 2.2.1 ?

Merci

En ce qui me concerne, la dernière mise à jour n’a rien changé : les backup TM fonctionnent, mais le partage AFP dans le finder ne fonctionne pas (”connexion en cours”... puis rien)

Project Manager
nipo commented on 12.12.2011 09:52

@unitednowhere: ça ne peut pas logiquement être matériel, donc logiquement c’est le soft, ou les réglages. Je voudrais bien m’assurer qu’il n’y a pas un réglage qui change entre vos deux setups. Pourriez-vous me donner les IP des lignes (ou les mac address des deux Server concernés) ?

J’ai le problème qui est survenu, sans raison particulière, il y a deux mois. Depuis, impossible de se connecter depuis l’icone du finder. J’arrive à me connecter via afp://freebox-server.local, mais la connexion est très instable. Samba apparait parfois dans le finder. Dans ce cas, je peux m’y connecter sans problème. Dans le cas contraire, un smb://Freebox n’aboutit pas et me bloque le finder jusqu’à ce que je reboote la freebox.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing