Freebox V5 ADSL

  • Status Nouveau
  • Percent Complete
    0%
  • Task Type Anomalie
  • Category Wifi
  • Assigned To No-one
  • Operating System Tous
  • Severity Medium
  • Priority Very Low
  • Reported Version 1.2.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Freebox V5 ADSL
Opened by vinz2k - 18/12/2006

FS#1295 - Réserver la bande passante WIFI pour la télévision

Bonjour !

Voila jai remarqué que lorsque j’utilise beaucoup la bande passante avec mes pc en wifi (p2p par exemple) , le boitier HD (connecté en wifi) a du mal a affiché la télévision correctement (freeze) Cela vient bien du wifi car lorsque je suis en multiposte connecté en ethernet je n’ai aucun freeze ....

Ce serait donc bien que le boitier HD ait la priorité sur les flux des connecté en wifi...

@+

ps : c est une copie du bug que j’ai déja mis sur le projet FREEBOX HD, je le met sur le projet freebox ADSL car je pense qu’il est plus approprié

Admin

Bonjour,

La priorité de la télévision pour le WIFI est deja au maximum (cf extensions WME/WMM). Mais, ce n’est pas pour autant qu’un transfert PC/Freebox n’a aucun effet.

Chaque trame envoyée entre station est émise avec un certain débit. L’AP (access point) change ce débit dynamiquement en fonction de la qualité du lien, si il ne reçoit pas de ack de la station à qui il envoit la trame, il réessaye à un debit inferieur. Si vous être tres loin, il peut essayer de vous envoyer les trames jusqu’à 1 Mbit/s.

Le temps d’envoi d’une trame peut ainsi devenir extremement lent, et va donc “consommer” une part importante de la bande passante disponible. Ainsi, si une station est associée à 54 M, et une autre a 1M, et que les deux téléchargent en meme temps, il ne restera pas 53M effectif pour la premiere, mais énormément moins.

Notez également que même si l’AP fait tout ce qu’il peut pour emettre les paquets videos avant les paquets de data, si une station fait des accès agressifs au réseau, par exemple elle n’attend pas le temps réglementaire entre chaque envoi de trame pour réessayer, elle va réduire l’efficacité de la QOS sur l’AP. Certains modes dit “boost”, “turbo”, de certains vendeurs, font exactement çà afin de grapiller quelques megabits, au détriment des autres...

Pour résumé, on ne peut pas faire de bande passante garantie sur du wireless, la freebox utilise les extensions WMM au mieux afin de donner la priorité au traffic video pour la freebox HD, mais dans les conditions extremes cela peut ne pas suffir.

okay !

merci pour tes précisions Maxime !

en gros faut pas trop abuser de sa connexion wifi (par exemple p2p) pour éviter de polluer le wifi de la maison...

on peut donc cloturer ce bug hein ! :)

Pour garantir le flux TV, il faut donc connecter les FB ADSL et HD en ethernet ?

Admin

L’espace ne vous appartient pas :) A partir de là, on ne peut rien garantir...

D’accord :)
Mais est ce que c’est sensé être plus sûr (puisque pas garanti) en ethernet qu’en WiFi ?
En gros, est ce que ça vaut le coup que je me fasse ch... à tirer un cable au travers mon salon ?

Admin

On ne s’est pas compris, l’espace ne vous appartient pas, donc pour les ondes on ne peut rien garantir.

Par contre votre cable ethernet blindé, vous pouvez lui faire confiance ;)

OK, j’ai connecté la FreeBox ADSL et la HD en éthernet depuis une semaine, et là, lorsque je laisse tourner mon logiciel de P2P, je n’ai plus que qqs freeze sur la TV de temps en temps sur les chaines de Canal+ qui sont plus sensibles que les autres pour une raison que je ne connais pas (peut être lié au codage de C+ du fait que ce sont des chaines cryptées ?).

Il arrive malgré tout encore que la HD n’arrive pas à démarrer lorsque j’utilise la mule (si je la coupe, c’est bon, je la redémarre après avoir démarré la HD... c’est juste un peu pénible...)
A part ça, tout baigne !

Bonne année à tous.

Admin

Ok pour le probleme de demarrage de la HD ca ira normalement beaucoup mieux avec le firmware 1.2.1.

Bonne année a vous aussi.

il se fait attendre ce 1.2.1 :p

Admin

J’avoue... Dommage pour le “Bonne année 2007” sur l’afficheur :)

oui! surtout qu’on a meme pas eu la mosaïque de noel comme les années passées ! :(

Admin

pub_magicien:

Si vous pouviez retester le demarrage de la HD avec votre P2P en même temps svp.

Merci,

P2P démarré :
- si WiFi entre HD et ADSL → pb démarrage HD (le bandeau du programme en cours s’affiche toutefois)
- si ethernet → tout marche nickel (pas de freeze : je regarde actuellement Star Wars épisode 3 sur la 404)
Je vais donc rester encore en ethernet !

Il me semble qu’il y a une inversion des chiffres dans les nouvelles infos affichées des débits réseau:
WAN R = 25 Ko/s E = 80 Ko/s
Ethernet R = 0 Ko/s E = 411 Ko/s
WiFi R = 83 Ko/s E = 25 Ko/s —→ eMule me dit 80 Ko/s en upload et 20 en download ⇒ inversion non ?!

Merci pour votre travail !

Non, en fait pas d’inversion, je crois comprendre que WiFi signifie “WiFi vu du boitier ADSL” alors que WAN doit signifier vu du réseau WAN... C’est ça ?

Admin

pub_magicien:

On s’est mal compris. J’ai cru comprendre d’apres votre dernier commentaire que meme avec la HD en ethernet, il y a avait un probleme lorsque celle ci demarre alors que le P2P tourne. J’avais mal compris ? Si non pouvait vous faire ce test (lancer le P2P et redemarrer la HD).

Pour l’inversion, tout est question de point de vue :) Si emule upload depuis votre PC, la freebox voit le trafic en reception.

Bonsoir Maxime,
vous aviez bien compris, j’avais aussi rencontré le pb en ethernet, mais il semble résolu avec le nouveau firmware.
En tout cas, ce topic a pour sujet le WiFi et la TV, et le pb en WiFi semble impossible à résoudre d’après vos réponses du 18 et 19 décembre, malgré l’utilisation des extensions WMM...

Je suis étonné de ne plus avoir du tout de freeze sur la TV depuis le nouveau firmware (est ce un hasard ? un petit bonus de débit ce soir ? un firmware au top ? :-))
Je ne sais pas ce que vous avez fait, mais ça a l’air efficace !
On peut supposer que ce sera encore mieux pour les soirs où le débit est limite lorsque les chaines seront diffusées en MPEG4 !
Merci encore (je suppose que vous pouvez désormais clore cet incident)

Admin

Bonsoir pug_magicien,

Ok il y a du mieux donc si la freebox HD arrive a démarrer en ethernet. Pour ce qui est des freezes TV, êtes vous sûr que ceux ci ne provenaient pas de la ligne ADSL ? Vous pouvez le voir en regardant les compteur HEC sur la page ADSL de la freebox ADSL. En principe, notre systeme de retransmission permet de les corriger, mais il n’est pas parfait. Au cas où ils apparaissent de nouveau, pensez à regarder svp.

Concernant la freebox HD en Wifi, ce n’est pas normal. Que ca freeze de temps en temps, soit, mais que le flux vidéo ne passe pas du tout, ca cache peut être quelque chose.

Votre PC Wifi est a quel distance de la freebox ? L’icone vous dit que vous être connecté à quel débit ? La freebox HD est a quelle distance ?

A l’occasion si vous avez le temps, pourriez vous remettre la freebox HD en wifi sur une chaine quelconque, lancer le P2P, et me dire quel débit vous obtenez en reception sur la HD (faites Start + Select et regardez la ligne wlan rx).

Merci pour vos tests,

je ferai ces tests lundi soir (je ne suis pas là ce week end)

En attendant et pour info, le fastpath est réglé en “sérénité” (je suis à 3050 m du DSLAM...)
affaiblissement = 44db
Chan data Interleave = 4544
HEC = 21 (mais pas significatif pour le moment, car redémarrage hier soir)

Je rappelle que le flux vidéo ne passe pas si je démarre la HD en WiFi alors que P2P déjà en route sur le PC (WiFi aussi)
Le PC est à la même distance que la HD du boitier ADSL (5 mètres), icône dans Win XP me dit 54 Mbits/s Force signal “Excellent”.
Un autre topic a été ouvert demandant de pouvoir avoir les mêmes infos sur la HD (ce serait pratique pour orienter les antennes et positionner au mieux la HD)... mais le nouveau firmware n’y répond pas encore...

Bon, à mon tour d’aller bosser : je suis informaticien, mais de jour, moi ;-) A lundi pour de nouvelles aventures en WiFi !

firmware 1.2.0 : bcp freeze sur TV en wifi
firmware 1.2.1 : freeze fini pendant 1 journée mais revenue :(

Mon PC utilise le cable, seul la TV est en Wifi

Comme demandé, j’ai remis la HD en WiFi et lancer mon logiciel de P2P.
Pas de download en cours (en attente de réception) → la HD a eu d’abord du mal à démarrer la TV, mais y arrive qd même en insistant (affichage liste des chaines et sélection de TF1 par ex) ou en zappant... (alors qu’en ethernet, ça marche directement)
Puis, j’ai ré essayé plusieurs fois → démarrage direct sans pb...
Ensuite, le download a commencé (faible à 21 Ko/s) → idem
Bizarre, jeudi dernier ça ne passait pas...

Il n’y a rien de changé par rapport à mes essais de jeudi, et pourtant, ça a l’air de fonctionner correctement...
Ca doit encore faire parti des phénomènes inexplicables...!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing